XP (slow) authentication in WG

Home Forums Client Operating Systems Windows 2000 Pro, XP Pro XP (slow) authentication in WG

This topic contains 12 replies, has 5 voices, and was last updated by Avatar Homeadmin 15 years, 10 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • Avatar
    Zeeshan
    Member
    #97618

    Perhaps someone can point me in the right direction…

    I have 3 computers in a WG, all of them XP. To connect I use a netgear ds104 on 100mbit.

    The problem I have is that the machines take at least 20 or 30 secs before they can make a connection to another machine or the router (and it was the same before I added the router last week for adsl).

    It seems like some validation problem. The router is dhcp but it also happened when fixed ip was used.

    Any suggestion anyone ?
    regards

    Avatar
    Marty
    Member
    #174916

    It could be a resolving issue as well…

    When you want to connect to a certain pc, do you use the hostname or the IP ?

    If using the hostname, try the following:
    */ edit %systemroot%system32driversetchosts file
    */ add IP & hostname of a certain pc
    */ test it

    Marty.

    Avatar
    bcastner
    Member
    #174861

    Remove the search for Scheduled Tasks. Daniel has a note on this, it is a pretty common issue and easy enough to remove: http://www.petri.com/speed-up_network_browsing.htm

    Avatar
    danielp
    Participant
    #167852

    one more thing you should try is to make sure than all computers use the same authenication type. Go to your NIC, properties, Authentication tab. What does it say?

    Avatar
    Marty
    Member
    #174917

    Sorry, I forgot to give some info with my last post…

    If I understand it correctly, you’re working in a same environment as myself. That is, I’ve got a small network linked to eachother with a Nexland router (8 ports switch). My router acts as DHCP server, but I don’t have a DNS or WINS server present.

    Correct me when wrong (and please do) but when trying to ping a host, it will always check first the local host file, then see for DNS/WINS resolution and then use NetBUI (broadcast). It could be possible that this cause the small extra amount of time to find the correct IP. If defining the IP and host in the local hosts file, it doesn’t need to search for DNS WINS, neither do a broadcast to find the correct IP…

    Thus my guess is that adding the IP and host in the local hosts file will give you a quicker respons…

    Daniel: please do correct me if I’m typing completely rubbish in here :wink:

    Marty

    Avatar
    danielp
    Participant
    #167853

    No, you’re right on the name resolution issue, however the latency between looking in the HOSTS file and querying the local DNS is minimal, surely not worth the 20-30 seconds interval…

    Let’s wait for the original poster’s reply. It could be some mis-config of his network, but we’re all guessing here.

    Avatar
    Marty
    Member
    #174918

    OK, querying the local DNS shouldn’t take that time, but I don’t think he has… Also when falling back to broadcast, it uses some little more time. All together it could make 20-30 seconds… Not?

    Cheers and thanks for the replay Daniel :)

    Avatar
    Anonymous
    #167813

    I think you guys are over complicating DNS issues.
    But perhaps not.

    In a similar Workgroup setting I have experimented with:

    . through DHCP on the router, forcing DNS to the router, most essentially are a DNS proxy;

    . through DHCP, forcing the DNS entries to the ISP entries as 1,2, and the fallback as the router address as DNS proxy server;

    . Entering directly in the router table the DNS for the respective ISP, rather than depend on the router’s own DHCP resolution of the addresses. The hope was that the router’s own route table would be more efficient.

    In the end the router does a decent job of routinig LAN vs. WAN DSL addresses.

    The issue is really pure Windows in this particular queston.

    . Remove the Scheduled Tasks overhead, as I mentioned above;
    . Deal cleanly with SMB signing issues;
    . Deal cleanly with oppotunistic locking issues;
    . Deal cleanly with Autodisconnect issues;

    See, for the last three points: http://support.microsoft.com/default.aspx?scid=kb;en-us;814112

    Be certain to read every link in that MS KB article.

    I think Microsoft itself is slightly chagrined by the Workgroup speed of Win2k and XP clients in mixed settings. See, for example, http://support.microsoft.com/default.aspx?scid=kb;en-us;811169

    Which is being held to the end of October, 2003. (And as I write this, it is 11/3/3002).

    Overall solution: let the router route, use DHCP on the clients through the router. Use the simple registry changes mentioned above to improve LAN browsing. Wait for Service Pack 2.

    For the incredibly inpatiant, you could adjust your SMB service with a carefull reading of Snakefoot’s site: http://snakefoot.fateback.com/tweak/winnt/network.html

    But I think it would be better to wait.

    Best,
    Bill Castner

    Avatar
    Homeadmin
    Member
    #174939

    Cheers

    Thanks for the effort and advise everyone. Thumbs !!

    Tonight it’s fixing time and I will apply all suggestions to see what may resolve this issue.

    I used to live with it before I subscribed to ADSL and it was no big deal since multiplayer LAN gaming was no problem. But now the problem makes Internet usage almost impossible. After a couple of minutes of browsing (especially if I take a break from clicking and read something for a change) the connection is lost and the browser states: “detecting proxy” followed by a “i cant find that page so sod it” and I need to reboot either the pc or the router/modem (zyxel 650)

    Will come back to let you know.

    Avatar
    Homeadmin
    Member
    #174940

    I tried all of the above but to no avail. I did some more tests though..

    Seem to have blackouts during LAN traffic. Internet will not show up during these breakdowns. dnslookup shows nothing is registering and neither does ping. Machines were reinstalled last week due to adsl that came up. I have normal dns resolution when the line is up.

    Avatar
    Marty
    Member
    #174919

    OK, tell me if I’m getting this right…

    Router which connects WG to the internet, 3 pc’s connected.
    DHCP is enabled. Did you configure fix IP’s by adding the MAC’s in the router? Because when working with the hosts file, it’s only interesting when you have fix IP addresses defined. Most router/switch boxes support that method…
    No DNS/WINS server present on your network.

    When internet goes down, you can’t do resolvement of any of the pc’s… Seems strange. Did you try to ping to the IP’s directly?

    Also on the pc side, what TCP/IP configuration did you set? Did you set DNS/WINS servers fixed (ex. those of your internet provider)?

    With other words, can you give in detail your configuration?

    Avatar
    Homeadmin
    Member
    #174941

    I can still ping the LAN pc’s. No ping results from Internet during blackouts. I have automatic DNS and no WINS (nothing but XP in my lan so no need). Though I did try to fix all IP settings (IP, provider DNS) and disabled DHCP. This did not help.

    What I did find on another forum is a thread about a similar problem which was resolved by replacing the hub by a switch. Today I bought one so I will see if it works… If not I will submit a complete system layout with ip config details and the works..

    Avatar
    Marty
    Member
    #174929

    Let us know, because I’m loosing it in this one…

    Marty

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.