Windows XP – Shadow Copy not working

Home Forums Client Operating Systems Windows 2000 Pro, XP Pro Windows XP – Shadow Copy not working

This topic contains 11 replies, has 6 voices, and was last updated by Avatar srinivas224 6 years, 6 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • Avatar
    hpfn
    Member
    #161117

    Hi Everyone

    I’ve been trying to virtualise an old Windows XP Pro machine in order to get rid of the hardware without loosing some of the applications I’m still using occasionally, but it keeps failing with Shadow Copy errors. I’ve searched for hours on the web for a fix and reinstalled, uninstalled and modified the registry with all kinds of fixes, but without success.
    At this stage the only alternative I can see is to just create a full backup and then try to restore it back to a virtual machine, however I have my doubts that this will fully work.
    So if someone has an idea how to either fix the VSS problem on Windows XP Pro or how to bypass the VSS error when converting with VMWare, please let me know.
    cheers
    hpfn :confused:

    Avatar
    Ossian
    Moderator
    #188076

    Re: Windows XP – Shadow Copy not working

    Can you please give us more of an indication of what the problem is, particularly any event log messages?

    What SP are you on?

    Avatar
    Virtual
    Member
    #334461

    Re: Windows XP – Shadow Copy not working

    hpfn;270535 wrote:
    Hi Everyone

    I’ve been trying to virtualise an old Windows XP Pro machine in order to get rid of the hardware without loosing some of the applications I’m still using occasionally, but it keeps failing with Shadow Copy errors. I’ve searched for hours on the web for a fix and reinstalled, uninstalled and modified the registry with all kinds of fixes, but without success.
    At this stage the only alternative I can see is to just create a full backup and then try to restore it back to a virtual machine, however I have my doubts that this will fully work.
    So if someone has an idea how to either fix the VSS problem on Windows XP Pro or how to bypass the VSS error when converting with VMWare, please let me know.
    cheers
    hpfn :confused:

    Have you tried converting Offline as in the XP PC has been powered off and restarted to start the process?

    Avatar
    biggles77
    Spectator
    #212856

    Re: Windows XP – Shadow Copy not working

    XP doesn’t have Shadow Copy capability. It can however utilise the Shadow Copy (via the Previous Version tab) option if it has been configured on Server 2003 and above (loved those MS adverts for 2003). Vista and Windows 7 have Shadow Copies but NOT XP Pro or Home.

    Avatar
    srinivas224
    Member
    #387777

    Re: Windows XP – Shadow Copy not working

    Hi Everyone

    Thanks for the replies & sorry I didn’t respond earlier but I have been away for a few days.
    The machine I’m trying to virtualise is running Windows XP Pro SP3 and I realise that XP does not have Shadow Copy like Win7, however it can do System State backups when running NTBackup.
    What is confusing though that VMWare converter fails with a ShadowCopy error and I can’t find a fix for it?

    hpfn

    Avatar
    wullieb1
    Moderator
    #244202

    Re: Windows XP – Shadow Copy not working

    Can you please tell us exactly what error message you receive and what software you are using to convert.

    Also please try this

    http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1016330

    Avatar
    srinivas224
    Member
    #387778

    Re: Windows XP – Shadow Copy not working

    Hi wullieb1

    I’ve downloaded the latest version of the VM-Converter Standalone this morning and installed it on the XP machine without problems, however when running the conversion it again fails with the same VSS error as when I tried previously across the network (see attached screen shot).
    I was hoping running the converter from the actual physical machine might bypass the attempt to run VSS.

    hpfn

    PS: couldn’t find anything related to VSS in the link doco

    Avatar
    wullieb1
    Moderator
    #244203

    Re: Windows XP – Shadow Copy not working

    hpfn;270779 wrote:
    Hi wullieb1

    I’ve downloaded the latest version of the VM-Converter Standalone this morning and installed it on the XP machine without problems, however when running the conversion it again fails with the same VSS error as when I tried previously across the network (see attached screen shot).
    I was hoping running the converter from the actual physical machine might bypass the attempt to run VSS.

    hpfn

    PS: couldn’t find anything related to VSS in the link doco

    Please check this doco from VMware. It describes exaclty your error.

    http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1019690

    Avatar
    srinivas224
    Member
    #387779

    Re: Windows XP – Shadow Copy not working

    Thanks wullieb1, I found this doco previously and followed the instructions a couple of weeks ago when I first started this project and had this error coming up, but without success. Just to make sure I went through all steps again last night but the error is still the same.
    I’m wondering if there is another method to virtualise a machine ie. with a dedicated boot disk without running the local O/S?
    hpfn

    Avatar
    wullieb1
    Moderator
    #244204

    Re: Windows XP – Shadow Copy not working

    There was a Cold Clone CD that was available to Enterprise customers but that is no longer available.

    This site will show you the steps required to create your own “Cold Clone” CD using a tool called MOA.

    http://www.ardamis.com/2009/04/25/cold-cloning-vmware-converter/

    Avatar
    srinivas224
    Member
    #387780

    Re: Windows XP – Shadow Copy not working

    Thanks wullieb1, sounds very interesting and will try the procedure as soon as time allows.
    I’ll report back on success or failure
    thanks very much for the link
    hpfn

    Avatar
    wullieb1
    Moderator
    #244207

    Re: Windows XP – Shadow Copy not working

    I never had much success with it but it didn’t matter as i had a Cold Clone Cd.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.