USB Modem with VPC 2007

Home Forums Virtualization Virtual Server & Virtual PC USB Modem with VPC 2007

This topic contains 5 replies, has 5 voices, and was last updated by Avatar Anonymous 9 years, 10 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • Avatar
    johnnixon
    Member
    #146384

    Hi All
    I want to use VPC for Internet access, using a USB SpeedTouch 330 on the host machine. Unfortunately, the USB device doesn’t show up in Network Connections, and therefore also not in VPC Settings for Network Connections. NAT Shared also doesn’t seem to connect, and pinging from host or VM doesn’t get replies. Is there a solution? Can the Loopback Adapter be used in some way?
    Much appreciate any ideas.

    Avatar
    Anonymous
    #368984

    Re: USB Modem with VPC 2007

    Whoops, forgot to say OS is WinXP SP2 on host and VM.

    tehcamel
    tehcamel
    Moderator
    #355300

    Re: USB Modem with VPC 2007

    I beleive that, if this is possible (and I suspect it’s not) you would have to pass the USB device through, so that the guest can see it.

    Virtualisation won’t understand it as a network interface, even if the host OS does..

    But with VirtualPC, you MIGHT be able to see the usb device, and add it, i’m not sure.

    I know you definitelyl cannot pass through usb devices with ESX

    Avatar
    sorinso
    Member
    #266935

    Re: USB Modem with VPC 2007

    You cannot see any USB devices attached to the host in a VirtualPC virtual machine (unless it is a drive and you map it to the VM).
    The only solution I see is to define ICS (Internet connection sharing) on the host, and use NAT in the VM settings.

    Avatar
    Anonymous
    #368985

    Re: USB Modem with VPC 2007

    Thanks Sorinso and Tehcamel for your trouble in replying. Since posting, I have had a chance to try out some settings, and have found one that works. For the sake of anyone else who wants this arrangement, here are the steps:-
    1. Install MS Loopback Adapter on host – http://support.microsoft.com/kb/839013
    2. Enable ICS on USB modem – http://support.microsoft.com/kb/314066
    3. Configure the share – http://support.microsoft.com/kb/306126 – on the Advanced tab referred to, open the drop-down list of connectors and select Microsoft Loopback Adapter
    4. In Virtual PC Settings dialogue, Network Settings, open the drop-down list of connectors and select Microsoft Loopback Adapter.
    5. I use Zone Alarm on the host machine – I had to modify this by creating a new Trusted Zone consisting of a range of IP addresses from 192.168.0.1 to 192.168.0.254 (as I left the Virtual Netwok Adapter on the virtual machine on DHCP). I also had to reduce the Internet Zone Security to Medium, as High blocks sharing. I then needed to disable Windows Firewall on the host and on the VM.
    6. If you have also decided to use DHCP to get the IP address for the virtual network device, you will have to provide a static DNS ip. By default it will be given the loopback adapter as its DNS, which will not provide the service. I did ipconfig/all in the host machine to find the ISP’s chosen DNS.

    What should happen now is that the Loopback adapter receives a static IP address of 192.168.0.1 and the VM adapter will be given a lease on an address in the range 192.168.0.2 – 254. Pinging host -> VM and VM -> host, also VM -> ISP and VM -> DNS should all produce replies. If not, toggling settings such as modem connected, shared, loopback adapter DHCP, VM adapter to local/loopback adapter, ipconfig/release-renew may eventually arouse the sleeping beast.
    Hope this helps someone, someday.

    Avatar
    danielp
    Participant
    #172124

    Re: USB Modem with VPC 2007

    Very nice post johnnixon, thanks for sharing!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.