Unable to install Windows Management Framework 2.0

Home Forums Server Operating Systems Windows Server 2000 / 2003 / 2003 R2 Unable to install Windows Management Framework 2.0

This topic contains 3 replies, has 3 voices, and was last updated by Avatar Anonymous 6 years, 2 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #162378

    All,

    I am trying to install WMF 2.0 onto Server 2003 SP2. I am sure I must have done something silly so ask you to check my work.

    Download and try to install 32 Bit WMF 2.0 (Windows5.2-KB968934-x86.exe)

    install fails with error in log:

    0.860: SOFTWAREMicrosoftNET Framework SetupNDPv3.5SP is Less Than Specified Value
    0.860: Second Condition in Prereq.CheckCLR.Section Failed

    Try to install .NET 3.5 SP1 (dotnetfx35SP1setup.exe)

    Install Fails with error in log:

    [09/19/13,09:24:57] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
    [09/19/13,09:25:34] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 is not installed.

    Try to install .NET3.0 SP2 (NDP30SP2-KB976570-x86.exe)

    Install Fails with error:

    None of the products that are addressed by this software update are installed on this computer. Click Cancel to exit setup.

    I have managed to install the WMF core, which has given me powershell, but just wondered why I couldn’t do the above, what have I missed, and why does .NET3.5 seem to require .NET3.0 SP2 which won’t install even though .NET3.0 is installed?

    Avatar
    Ossian
    Moderator
    #188900

    Re: Unable to install Windows Management Framework 2.0

    How are you installing .NET 3.5 – manually or as part of the install package?

    Try a reinstall of .net 3.0 (direct download) then patch, then install 3.5

    Alternatively try jumping a level and installing 4.0 (as it includes all 3.5 assemblies)

    #314490

    Re: Unable to install Windows Management Framework 2.0

    Ossian,

    I tried installing .NET 4.0 at your suggestion, but it made no difference.

    I think I will uninstall all versions, reboot and try again but this is a production DC and I cant do this during the day (or just before I go on holiday) so it’ll have to wait a while.

    thanks for the advice. I’ll look at it again when I am back from my Hols.

    Avatar
    Anonymous
    #371605

    Re: Unable to install Windows Management Framework 2.0

    Grab this Microsoft .NET cleanup tool (http://www.microsoft.com/en-gb/download/details.aspx?id=30135). If there’s something not right with any/all .NET installs, it’ll strip out what you select from the GUI, then you can reinstall the basic components, patch them, and carry on. I’ve used several times and never had any issues.it

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.