Task Scheduler suddenly will not run exe’s in a script

Home Forums Server Operating Systems Windows Server 2012 / 2012 R2 Task Scheduler suddenly will not run exe’s in a script

This topic contains 3 replies, has 3 voices, and was last updated by CaTBuS CaTBuS 3 years, 3 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • CaTBuS
    CaTBuS
    Participant
    #166352

    I have a script (bat file) that has been running successfully for months until recently. Suddenly, this script works save the part that calls an exe. The bat file will run fine manually but fails at the exe call when run through Task Scheduler. To dumb it down a bit and prove my hypothesis, I wrote the following bat file:

    Code:
    [USER=”68995″]Echo[/USER] OFF
    notepad.exe
    EXIT

    When run manually, it launches notepad and persists until notepad is closed. When I run it via Task Scheduler, it does nothing. It wont even exit its RUNNING state. I’ve tried this in Win7, Win8, and Server 2008 R2 and it runs fine both ways. Its only on my 2012 R2 servers where this is a problem. Something has changed and I can’t figure out what it is.

    Any thoughts?

    Avatar
    Ossian
    Moderator
    #191220

    Any recent patches applied?
    (that is normally the reason for sudden changes of this sort)

    If so, try rolling them back one by one

    Avatar
    danielp
    Participant
    #172715

    Besides Ossian’s reply – were there any GPO changes? Any new restrictions? Any change in UAC level? What user account are you using to schedule the task?

    CaTBuS
    CaTBuS
    Participant
    #309111

    I can confirm that there have been no patches applied, UAC changes, and no GPO changes. These particular servers are in a managed group and get no updates deployed without being selected by me. Having said that, our InfoSec group is notorious for operating like the KGB and on more than one occasion have been caught “messing around” without submitting proper change requests.

    As for user accounts, I’m using a logon-able service account with local admin rights. I’ve also tried using a standard service account with the same local admin access as well as just local system account. No account can even open notepad via task scheduler.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register for this Petri Webinar!

Want to Make Your Backup Storage Unlimited & Ready for the Cloud? – Free Thurrott Premium Account with Webinar Registration!

Tuesday, August 27, 2019 @ 1:00 pm EDT

A Scale-Out Backup storage infrastructure is a must-have technology for your backups. In this webinar, join expert Rick Vanover for a look on what real-world problems are solved by the Scale-Out Backup Repository.

Register Now

Sponsored By