SMS secondary Site problem

This topic contains 8 replies, has 3 voices, and was last updated by Avatar noway 13 years, 10 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • Avatar
    noway
    Member
    #111424

    I have a problem and I hope you guys can solve it for me…

    In our main office we have SMS 2003 SP2 running without any problem we decide to do install SMS secondary site in our branch office. I will give you some details :

    Main Office:
    Abc.com and SMS site code MSM

    Branch Office:
    Xyz.com and SMS site code BUT

    Now, the SMS can discover all the computers in the branch site and I can see them in the SMS Administrator Console. However, they are not assigned to any site code. What I mean is when I try to let the SMS advance clint discover the site code it will give me an error.

    So my Q. is how can I let all the computer in the branch office discover the site code of the branch or the main office.

    Please help me..

    Avatar
    yuval14
    Member
    #173553

    Re: SMS secondary Site problem

    SMS use active directory sites or/and subnets to locate computers etc.
    Also, discover process mean that SMS client will be install on any clients.

    http://www.microsoft.com/technet/prodtechnol/sms/sms2003/cpdg/plan906x.mspx?mfr=true

    Regards,

    Yuval

    Avatar
    yanivfel
    Member
    #221406

    Re: SMS secondary Site problem

    Hi Nowey,

    From what i understand, your secondary site is in another domain then your primary site. if so, SMS 2003 does not support this configuration. in order for these to work (cross-domains) you need to create a primary site in the branch office and make it a child of the primary site in your main office (under properties of site settings).

    If that is not the case and this is one domain, you should check your secondary site bounderies, they might not be configured properly and that could be the reason why your clients can seem to detect their site assigment.

    please post here your situation (between the two i mentioned) and i’ll be happy to guide you thorugh the process of making this work :-)

    Best Regards,

    Avatar
    noway
    Member
    #236489

    Re: SMS secondary Site problem

    thank you yanivfel for you post..

    well it is two difference domain and there is a forest trust relationship between the two domain.

    What I nosiest is that some of the computers in the branch are assign to MSM codesite and I can remote them. However, this is only happening if a computer “A” in the main office disjoined from abc.com domain then moved and join the xyz.com domain. Also, other computers that is not joined to abc.com domain before well not be assigned to the sitecode MSM.

    What I mean is when we format a computer in the main office and joined to the domain the SMS well see the computer and install the advance client and it will detect the MSM sitecode. If this computer disjoined from abc.com and moved to xyz.com domain and join the domain, then I can see this computer in the SMS console and I can remote it without any problem. However, if a computer has been formatted in the xyz.com domain and join the domain after that I can see the computer in the SMS console but I can not remote it because it is not assigned to any domain sitecose.

    I hope you got what I mean…

    Avatar
    yanivfel
    Member
    #221409

    Re: SMS secondary Site problem

    Hi Again Nowey,

    what you say is very reasonable since if you install the client on the abc.com domain it can find all the data it needs to configure itself in abc.com’s AD (such as MP and SLP location), and once he is assigend to the main office site it does not need the AD info anymore so if you relocate him, he “still works”.

    if you have to work with two domains, the only solution for you is to uninstall the secondary site and reinstall a primary site at your xyz.com domain and attach it as a child to the abc.com site.

    secondary sites in another domain will not work and will not communicate properly due to credentials problems.

    if you need further assitance, feel free to ask :-)

    Best Regards,

    Avatar
    noway
    Member
    #236490

    Re: SMS secondary Site problem

    Thanks..

    but i have two Q.?

    Q1: doe it work if i configre the MP for the banch site?

    Q2: how i can make the office paresnt site a chiled in the main office?

    Avatar
    noway
    Member
    #236491

    Re: SMS secondary Site problem

    Thanks..and soory for the last post…

    but I have two Q.?

    Q1: doe it work if I configure the MP for the branch site?

    Q2: how can I make the office parent site as a child in the main office?

    i think if change some setting i will be able to let the computer detect the sms site code.? what do you think???

    Avatar
    yuval14
    Member
    #173554

    Re: SMS secondary Site problem

    Please review:

    https://www.microsoft.com/technet/prodtechnol/sms/sms2003/cpdg/plan84vu.mspx

    Regards,

    Yuval

    Avatar
    yanivfel
    Member
    #221413

    Re: SMS secondary Site problem

    hi again,

    there are possible tweaks that will do the job of enabling clients to discover site code automaticly, but they won’t be able to work properly because advanced clients are assigned and communicate with primary sites only (the secondary is only using as a proxy) and will not be able to work because of cross-domain credentials problem.

    in order to make a child site you should install a Primary site (not a secondary) in the branch office.
    before you set the parent site, you should create an address for the parent site on the child site (and create an address for the child site on the parent).
    you can do this under site database -> site hierarchy -> Site name -> site settings -> right click addresses -> new -> standard sender address and fill the details of the parent server (or child respectively).
    after you create the addresses in both sites, expand site settings, expand site database and then right-click->properties on the site itself. on the properties page, you should have button called set parent site.

    Good luck!

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.