Single user unable to auto-forward/auto-redirect to external address

Home Forums Messaging Software Exchange 2007 / 2010 / 2013 Single user unable to auto-forward/auto-redirect to external address

This topic contains 3 replies, has 3 voices, and was last updated by  hemanthkumar 1 month, 4 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts

  • OhmSweetOhm
    Member
    #167698

    We have a single user (me) that is unable to use Outlook 2016 rules to automatically forward or redirect mails outside of the company. I can auto-forward and auto-redirect email internally.

    We have only one remote domain set up and it allows automatic fowarding. I have no transport rules in place to stop it from happening for me. We did set up some transport rules to prevent auto-forwarding and auto-redirect for specific groups of users but I’m not a member of any of those. I deleted and recreated my rules in Outlook. I deleted and recreated my Outlook profile on the client workstation. I ran a repair installation on Outlook. I tried creating the rules in OWA. I ran a check against my mailbox for corruption – there was none. I also compared a get-mailbox | FL against a user that is able to auto-forward/auto-redirect and besides the obvious account differences they’re identical. I looked at my properties in ADSIedit and nothing jumps out at me. We have a spam filter in the DMZ that has message tracking but it doesn’t look like the email is even getting to that point. Sounds to me like it’s a server side thing, but I’m at a loss where to go from here troubleshooting this issue. Will welcome any thoughts or insights on where to look or how to fix.


    Ossian
    Moderator
    #192104

    Can you tell us a bit more about the Exchange environment (version, on prem or cloud….)

    Have you tried creating a mail contact for the external address and forwarding to that?


    hemanthkumar
    Member
    #392097

    Running Exchange 2010 SP3 UR21 on prem. 2 CAS/HUB servers, 2 mailbox, 1 with all 3 roles, 3-node DAG.

    Yes, I tried creating a contact and it didn’t work either. However, if I create a Transport Rule in Exchange it does work (except for emails marked with high importance”.

    Did a little more testing and when I do a Get-MessageTrackingLog and try to send using Outlook rules I get:
    EventId Source Sender Recipients MessageSubject
    RECEIVE AGENT myemailaddress.com theforwardingaddress.com Test
    DEFER AGENT myemailaddress.com theforwardingaddress.com Test
    TRANSFER ROUTING myemailaddress.com theforwardingaddress.com Test
    SEND SMTP myemailaddress.com theforwardingaddress.com Test

    When it’s sent using the transport rule I basically get:
    RECEIVE SMTP myemailaddress.com theforwardingaddress.com Test
    SEND SMTP myemailaddress.com theforwardingaddress.com Test


    hemanthkumar
    Member
    #392099

    Finally ended up burning a support ticket with Microsoft. Although they didn’t come up with the exact answer they did lead me to another Google search expedition where I found an obscure post here:

    https://superuser.com/questions/880048/outlook-redirect-rule-ignoring-exceptions

    Where the following comment was made that seems to explain why I was unable to trigger on the domain name in the SMTP address:

    “The problem is that purely internal email does not seem to be evaluated by the full smtp address, so your rule won’t work if the email has never left the server.”

    The workaround was to specify a word or phrase in the message header, which is:

    “X-MS-Exchange-Organization-AuthAS: Internal”

    Which will look for emails generated internally. Seems to work.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.