RIP – What I missed ?

Home Forums Networking Cisco Routers & Switches How-to RIP – What I missed ?

This topic contains 3 replies, has 3 voices, and was last updated by Avatar BigDeesDad 10 years, 3 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • Avatar
    Flanfl
    Member
    #145180

    Hi,

    I’ve 3 routers and a computer build like that : PC—-R1—-R2—-R3.
    I set all routers with RIP protocol. Each router can ping all interfaces of the routers.
    R1 can ping the PC the PC can ping R1 (only the interfaces that the PC is connected to R1). The other routers cannot ping the PC and vice versa.

    So I think I missed something in my configuration but what ? I’m sure that’s really stupid…

    Configuration of R1:

    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname R1
    !
    !
    memory-size iomem 15
    ip subnet-zero
    !
    !
    !
    !
    call rsvp-sync
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.4.2 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 192.168.2.2 255.255.255.0
    duplex auto
    speed auto
    !
    router rip
    network 192.168.1.0
    network 192.168.2.0
    network 192.168.4.0
    !
    ip classless
    ip http server
    !
    !
    dial-peer cor custom
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    !
    end
    [/CODE]
    R2:
    [CODE]!
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname R2
    !
    !
    memory-size iomem 15
    ip subnet-zero
    !
    !
    !
    !
    call rsvp-sync
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.2.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    router rip
    network 192.168.2.0
    !
    ip classless
    ip http server
    !
    !
    dial-peer cor custom
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    !
    end
    [/CODE]
    Routing table of R1:

    C 192.168.1.0/24 is directly connected, FastEthernet0/0
    C 192.168.4.0/24 is directly connected, FastEthernet0/1
    C 192.168.2.0/24 is directly connected, Ethernet1/1

    Routing table of R2:

    C 192.168.2.0/24 is directly connected, FastEthernet0/0
    R 192.168.1.0/24 [120/1] via 192.168.2.2, 00:00:13, FastEthernet0/0
    R 192.168.4.0/24 [120/1] via 192.168.2.2, 00:00:15, FastEthernet0/0[CODE]version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname R1
    !
    !
    memory-size iomem 15
    ip subnet-zero
    !
    !
    !
    !
    call rsvp-sync
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.4.2 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 192.168.2.2 255.255.255.0
    duplex auto
    speed auto
    !
    router rip
    network 192.168.1.0
    network 192.168.2.0
    network 192.168.4.0
    !
    ip classless
    ip http server
    !
    !
    dial-peer cor custom
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    !
    end
    [/CODE]
    R2:
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname R2
    !
    !
    memory-size iomem 15
    ip subnet-zero
    !
    !
    !
    !
    call rsvp-sync
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.2.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    router rip
    network 192.168.2.0
    !
    ip classless
    ip http server
    !
    !
    dial-peer cor custom
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    !
    end
    [/CODE]
    Routing table of R1:

    C 192.168.1.0/24 is directly connected, FastEthernet0/0
    C 192.168.4.0/24 is directly connected, FastEthernet0/1
    C 192.168.2.0/24 is directly connected, Ethernet1/1

    Routing table of R2:

    C 192.168.2.0/24 is directly connected, FastEthernet0/0
    R 192.168.1.0/24 [120/1] via 192.168.2.2, 00:00:13, FastEthernet0/0
    R 192.168.4.0/24 [120/1] via 192.168.2.2, 00:00:15, FastEthernet0/0[CODE]!
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname R2
    !
    !
    memory-size iomem 15
    ip subnet-zero
    !
    !
    !
    !
    call rsvp-sync
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.2.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    router rip
    network 192.168.2.0
    !
    ip classless
    ip http server
    !
    !
    dial-peer cor custom
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    !
    end
    [/CODE]
    Routing table of R1:

    C 192.168.1.0/24 is directly connected, FastEthernet0/0
    C 192.168.4.0/24 is directly connected, FastEthernet0/1
    C 192.168.2.0/24 is directly connected, Ethernet1/1

    Routing table of R2:

    C 192.168.2.0/24 is directly connected, FastEthernet0/0
    R 192.168.1.0/24 [120/1] via 192.168.2.2, 00:00:13, FastEthernet0/0
    R 192.168.4.0/24 [120/1] via 192.168.2.2, 00:00:15, FastEthernet0/0

    Avatar
    BigDeesDad
    Member
    #366376

    Re: RIP – What I missed ?

    If the routers can ping each interface then there is no problem with the routing, as confirmed with the routing table output below for R1 and R2. The outputs show only 2 routers?

    Sounds like you have not configured the default gateway of the PC. Check the folowing PC config

    IP Address: 192.168.4.x
    Subnet mask: 255.255.255.0
    Default Gateway: 192.168.4.2

    Avatar
    ikon
    Member
    #354266

    Re: RIP – What I missed ?

    C 192.168.2.0/24 is directly connected, Ethernet1/1

    This doesnt seem right to me on R1…

    Avatar
    BigDeesDad
    Member
    #366377

    Re: RIP – What I missed ?

    Looks like it is just a mistake when they were writing down the routing table. If you look at the config of R1, the routing table does not match any interface.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.