Remove ADFS Role

This topic contains 2 replies, has 2 voices, and was last updated by  h0me 1 year ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts

  • todd231
    Participant
    #167317

    We have a client that was using ADFS, they’re now on Azure AD Connect. The ADFS role is on their RDP server (Don’t ask me why…). They had SBS until September when I went in and installed Server 2016 on their DC.

    The problem is that the Remote Management software we’re using has an alert for all of the servers that have the ADFS role, this RDP server is triggering that alert so I need to get that role uninstalled.

    Since it’s an RDP server and hardly ever used, this should be easy, but apparently it’s not.

    Anyone able to point me in the right direction? Uninstalling the role is grayed out so I can’t go that route, and the previously installed update isn’t there.


    h0me
    Member
    #377632

    So I went through all of the “Steps” that I found…

    SQL is not installed on that server.

    I removed the adfs files in c:widowswiddata

    Finally, I ran Remove-WindowsFeature adfs-federation and it removed the role.

    The server, however, is still showing up in our RM software as having the ADFS role installed. I’m thinking it may just have to check in and update itself in inventory.

    Will report back.


    h0me
    Member
    #377633

    So that worked. I haven’t had to remove it from a DC yet, I don’t think we have it installed on any DC’s, if we do it’s only one…

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.