Problem with networking after exporting and importing virtual machine running Ubuntu

Home Forums Virtualization Microsoft Hyper-V Technology Problem with networking after exporting and importing virtual machine running Ubuntu

This topic contains 4 replies, has 5 voices, and was last updated by Avatar EarthReactor 4 years, 10 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • Avatar
    davids355
    Member
    #165270

    Hi guys,
    I have a virtual machine running on a Hyper-V host.
    The machine is running ubuntu and was running without any issues.
    I wanted to move the VM to a second harddrive in the same server so I exported it to that second hard drive and then imported it.

    Since doing so I have lost Internet access on the VM.

    I can restore Internet connectivity simply by running a command to add a default gateway, but once I reboot, Internet connectivity is again lost.

    The gateway is configured in the network settings so it is strange how this issue has started to occur.

    I have posted on Ubuntu forums and none of their suggestions have worked so far so it doesn’t appear to be an obvious problem.

    I know this forum isnt really focused on linux but I wondered if you guys had any idea what might have occured during the export/import process to cause an issue like this….???

    Avatar
    biggles77
    Spectator
    #213755

    Does it have the same name in Settings–> Network Adapter–>Network–> Local Area Network?

    Avatar
    Ossian
    Moderator
    #190616

    I have seen this with imports on a different server where HV doesn’t pick up the same virtual network – WIndows loses the old adaptor on the VM. Not sure about Linux, and since it is on the same HyperV server it should not apply.

    JeremyW
    JeremyW
    Moderator
    #271174

    You need to set a static MAC address of the Linux VM or else you’ll continue to have this issue. (Linux keys off the MAC address for identifying the interface, Hyper-V dynamically sets the MAC address every time it boots)

    Avatar
    EarthReactor
    Member
    #377244

    Hi guys,
    The network settings are the same.
    I have even tried creating a new network adaptor in hyperV and then assigning IP settings to it but it did not help.

    Jeremy I take your point about the MAC address though, I’ll have a mess around with that today and see if it resolves the issue.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.