Problem Demoting a DC

This topic contains 2 replies, has 2 voices, and was last updated by tehcamel tehcamel 9 years, 6 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • Avatar

    Hi all,
    Im working in a child domain, the domain has 2 DCs, gvanet1 and gvanet3.

    Im trying to demote gvanet3, we are in the process of migrating to a single domain model instead of parent/child/external.

    When I run dcpromo, I hit next on the screen asking to indicate whether this is the last DC in the domain (without checking the box because its not!) I get this message:

    You did not indicate that this AD DC is the last DC for the domain
    However, no other AD DCs for that domain can be contacted.

    Do you want to proceed anyway?

    bleh bleh

    My problem is this is not the last DC in the domain.

    I run netdom query fsmo and it returns:

    Schema master
    Domain naming master
    RID pool manager
    Infrastructure master
    (replaced my domain with a z)

    I then did:
    Default Server:
    > set type=srv
    Address: SRV service location:
    priority = 0
    weight = 100
    port = 389
    svr hostname = internet address =

    I also get an error when I try to open the AD Domains and Trusts mmc, it also says it cannot locate a PDC.

    Im running a dcdiag /e /c /v /f:dcdiag.txt now and can post the results tomorrow when its done.

    I did run a straight up dcdiag and saw this:

    Running enterprise tests on :
    Starting test: LocatorCheck
    Warning: DcGetDcName(PDC_REQUIRED) call failed, error 1355
    A Primary Domain Controller could not be located.
    The server holding the PDC role is down.
    ……………………. failed test LocatorCheck

    These servers are Windows server 2008. I ran all of those commands above from GVANET3, thats the guy thats giving me problems. oh, and I dont want to force the demotion because we dont know if there is an sidhistory or anything being used over there.

    Does anyone know what I can do to fix this so I can demote the DC? Thanks!


    Re: Problem Demoting a DC

    run the DCdiag commands, and even the demote command, from an elevated command prompt.

    I’ve found with 2008, that even being a full DA or EA sometimes isn’t enough.


    Re: Problem Demoting a DC

    Hi Tehcamel,

    Ive tried using an elevated command prompt, I know what you mean about 2008 requiring it sometimes. Unfortunetly I think the problem is a little deeper especially considering I cant open the domains and trusts mmc without it barking about not finding the PDC.

    Thanks for the input!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.