need help with CS.ini language section

Home Forums Scripting General Scripting need help with CS.ini language section

This topic contains 10 replies, has 2 voices, and was last updated by Avatar mla 6 months, 3 weeks ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • Avatar
    mla
    Participant
    #615290

    Hi,

    a week ago I asked the question below on Microsoft MDT forum. Many views but no answer.

    I decided to ask here, since in the past received nice solution.

    The question looks bulky. But I guess easy to understand. Not sure if there is an answer :)… tricky stuff involving language settings.

    Thanks.
    <ul id=”rootMessage” class=”message root”>
    <li id=”3d70cba0-916b-4e6a-a716-1a3dcec0f803″ class=”message root”>
    <div class=”messageContentContainer”>
    <div class=”messageContent”>
    <div class=”container”>
    <div class=”body”>

    **************************************

    during years I was trying to find a solution for getting right keyboard (Input Locale) entry after deployment and could not find any post leading to the final solution.

    The issue:

    I am deploying French OS and the problem I am referring to is: the keyboard I am getting is “French – Multilingual” when Locale is “French – (Canada)”. And I need Input Locale “Canadian French”.

    Here is the entry that I am using in CS.ini :

    <span lang=”EN-US”>SkipLocaleSelection=YES</span>

    <span lang=”EN-US”>KeyboardLocale=”fr-ca; 0c0c:00001009″</span>

    UserLocale=fr-CA

    UILanguage=fr-FR

    It worked for me many years ago when used WDS for XP deployment. And never worked when started with MDT 2010 for W7 deployments.

    Today I am on 8456 for W10 Deployment and eager to resolve the issue.

    Searched again the web for similar question. Nothing concrete. But found one where MSFT employee explains the issue for the same question posted for sysprep of Windows 2000 :).

    And I guess in his explanation there is a correct syntax for the fix. My problem is I don’t know how to properly use it in CS.ini

    I will appreciate if somebody will take a look in the explanation below and can put the syntax in CS format.

    HERE IT IS: (for ease of reading here is the link: https://www.pcreview.co.uk/threads/french-canadian-keyboard.1602642/ )

    The below steps describe how an administrator can obtain the French Language
    as the Default language after Sysprep.  To get this desired behavior the
    steps below must be completed:

    – Overriding the default behaviour of the Regional Options control panel

    – Specify the correct and valid values in the [Regional Settings]
    section of sysprep.inf

    MORE INFORMATION
    ================

    Overriding the default behaviour of the Regional Options control panel

    By design the Regional Options control panel installs one specific Input
    Locale per User Locale. The Input Locale installed with the “French
    (Canada)” User Locale is “French (Canada) – Canadian Multilingual Standard”.

    To change this behavior, the file “intl.inf” needs to be modified to install
    a different Input Locale for the appropriate User Locale. In this particular
    case, we describe how a customer can have “French (Canada)” as the User
    Locale and “French Canadian – French” as the default Input Locale:

    Step 1:

    Modify %windir%\inf\intl.inf

    Find the line that begins with “00000c0c = %French_Canadian%” and replace
    the entire line with:

    00000c0c = %French_Canadian% ,850 ,1,,0c0c:00001009

    This will set “French (Canada) – Canadian French” as the default Input
    Locale when “French (Canada)” is installed as the User Locale.

    Specifying correct values in the [Regional Settings] section of sysprep.inf

    It’s important to get these values correct.

    Correct values for the UserLocale and SystemLocale settings are:

    00001009 for “English (Canadian)”
    00000c0c for “French (Canadian)”

    Correct values for the InputLocale setting are any comma-delimited
    combination of:

    0c0c:00000409    “French (Canada) – US”
    0c0c:00001009    “French (Canada) – Canadian French”
    0c0c:00011009    “French (Canada) – Canadian Multilingual Standard”

    Step 2:
    Specify correct values in [RegionalSettings]

    Use the following [RegionalSettings] section:

    [RegionalSettings]
    LanguageGroup=1
    SystemLocale=00000c0c
    UserLocale=00000c0c
    InputLocale=0c0c:00000409

    This will set “French (Canada)” as the System Locale and the User Locale. It
    will also add “French (Canada) – US” as a second Input Locale. Note that
    “French (Canada) – Canadian French” will be installed as the default Input
    Locale once the User Locale is set to 00000c0c (provided step 1 above has
    been followed).

    </div>
    </div>
    </div>
    </div>

     

    Avatar
    wullieb1
    Moderator
    #615354

    What is your question exactly?? Are you looking on how to configure MDT to set you region/language settings to French Canadian? I believe this is what you are doing.

    This is pretty much all you need to do, and has been for a long time.

    MDT 2010: UK Regional Settings (Windows 7/Vista)

    KeyboardLocale=0c0c:00001009
    UserLocale=fr-CA
    UILanguage=fr-CA

    SkipTimeZone=YES
    TimeZoneName=GMT Standard Time

    You will need to update the timezone as i have no idea which one.

    • This reply was modified 7 months, 1 week ago by Avatar wullieb1.
    Avatar
    mla
    Participant
    #615367

    Hi,

    > <span style=”background-color: #e6e6e6; color: #4d4d4d; font-family: ‘open sans’, helvetica, arial, sans-serif; font-size: 14px;”>What is your question exactly?? Are you looking on how to configure MDT to set you region/language settings to French Canadian? I believe this is what you are doing</span>

    It is exactly what I am trying to fix …

    1. this is my current entry that brings Francais Multilingual and not Francais-Canada that I need:

    <span style=”color: inherit; font-family: inherit; font-size: inherit; font-style: inherit; font-variant-ligatures: inherit; font-variant-caps: inherit; font-weight: inherit;”>SkipLocaleSelection=YES</span>
    <p class=”x_MsoNormal” style=”-webkit-font-smoothing: antialiased; margin: 0in 0in 0.0001pt; font-size: 11pt; font-family: Calibri, sans-serif; color: #212121;”><span lang=”EN-US” style=”-webkit-font-smoothing: antialiased; margin: 0px; padding: 0px; border: 0px; font: inherit; vertical-align: baseline; color: inherit;”>KeyboardLocale=”fr-ca; 0c0c:00001009″</span></p>
    <p class=”x_MsoNormal” style=”-webkit-font-smoothing: antialiased; margin: 0in 0in 0.0001pt; font-size: 11pt; font-family: Calibri, sans-serif; color: #212121;”>UserLocale=fr-CA</p>
    <p class=”x_MsoNormal” style=”-webkit-font-smoothing: antialiased; margin: 0in 0in 0.0001pt; font-size: 11pt; font-family: Calibri, sans-serif; color: #212121;”>UILanguage=fr-FR</p>
    2. the only difference with yours proposal is that I have fr-ca in KeyboardLocale line.

    As mentioned it not works.

    3. I started the thread because in found info I see the point where <span style=”background-color: #e6e6e6; color: #4d4d4d; font-family: ‘open sans’, helvetica, arial, sans-serif; font-size: 14px;”>0c0c:00011009 is mentioned for both Candadian French and Canadian Multilingual Standard</span>
    <p style=”box-sizing: border-box; color: #4d4d4d; font-family: ‘open sans’, helvetica, arial, sans-serif; font-size: 0.875em; margin: 0px 0px 1.25em; background-color: #e6e6e6;”>Correct values for the InputLocale setting are any comma-delimited<br style=”box-sizing: border-box;” />combination of:</p>
    <p style=”box-sizing: border-box; color: #4d4d4d; font-family: ‘open sans’, helvetica, arial, sans-serif; font-size: 0.875em; margin: 0px 0px 1.25em; background-color: #e6e6e6;”>0c0c:00000409    “French (Canada) – US”<br style=”box-sizing: border-box;” />0c0c:00001009    “French (Canada) – Canadian French”<br style=”box-sizing: border-box;” />0c0c:00011009    “French (Canada) – Canadian Multilingual Standard”</p>
    4. further I saw another language code and thought that may be this <span style=”background-color: #e6e6e6;”><span style=”color: #4d4d4d; font-family: open sans, helvetica, arial, sans-serif;”><span style=”font-size: 14px;”>InputLocale=0c0c:00000409 will “help” to differentiate </span></span></span><span style=”background-color: #e6e6e6;”><span style=”color: #4d4d4d; font-family: open sans, helvetica, arial, sans-serif;”><span style=”font-size: 14px;”>00000c0c that is common for Canadian French and Canadian Multilingual Standard. The article where I found it was referring to sysprep stuff but I see it as something that may help</span></span></span>
    <p style=”box-sizing: border-box; color: #4d4d4d; font-family: ‘open sans’, helvetica, arial, sans-serif; font-size: 0.875em; margin: 0px 0px 1.25em; background-color: #e6e6e6;”>[RegionalSettings]<br style=”box-sizing: border-box;” />LanguageGroup=1<br style=”box-sizing: border-box;” />SystemLocale=00000c0c<br style=”box-sizing: border-box;” />UserLocale=00000c0c<br style=”box-sizing: border-box;” />InputLocale=0c0c:00000409</p>
    <p style=”box-sizing: border-box; color: #4d4d4d; font-family: ‘open sans’, helvetica, arial, sans-serif; font-size: 0.875em; margin: 0px 0px 1.25em; background-color: #e6e6e6;”>This will set “French (Canada)” as the System Locale and the User Locale. It<br style=”box-sizing: border-box;” />will also add “French (Canada) – US” as a second Input Locale. Note that<br style=”box-sizing: border-box;” />“French (Canada) – Canadian French” will be installed as the default Input<br style=”box-sizing: border-box;” />Locale once the User Locale is set to 00000c0c (provided step 1 above has<br style=”box-sizing: border-box;” />been followed).</p>
    Am I in a right way of thinking? I have no luck for getting French Canada. Just French Multilingual after deployment with MDT.

    And yes I don’t have issue with the Time Zone that is set to Eastern Standard Time.

     

    Avatar
    mla
    Participant
    #615368

    sorry I see the page formatting of the site makes unreadable the text …

    will try to redo all in notepad

    Avatar
    mla
    Participant
    #615369

    Hi,

    >What is your question exactly?? Are you looking on how to configure MDT to set you region/language settings to French Canadian? I believe this is what you are doing

     

    It is exactly what I am trying to fix …

     

    1. this is my current entry that brings Francais Multilingual and not Francais-Canada that I need:

    SkipLocaleSelection=YES

    KeyboardLocale=”fr-ca; 0c0c:00001009″

    UserLocale=fr-CA

     

    UILanguage=fr-FR

     

    2. the only difference with yours proposal is that I have “fr-ca;” in KeyboardLocale line.

     

    As mentioned it not works.

     

    3. I started the thread because in found article I see the point where the code “0c0c:00001009” corresponds to both Canadian French and Canadian Multilingual Standard:

     

    0c0c:00000409 “French (Canada) – US”

    0c0c:00001009 “French (Canada) – Canadian French”

    0c0c:00011009 “French (Canada) – Canadian Multilingual Standard”

     

    4. further I saw another language code “InputLocale=0c0c:00000409” with the explanation:

     

    Use the following [RegionalSettings] section:

    [RegionalSettings]

    LanguageGroup=1

    SystemLocale=00000c0c

    UserLocale=00000c0c

    InputLocale=0c0c:00000409

     

    This will set “French (Canada)” as the System Locale and the User Locale. It

    will also add “French (Canada) – US” as a second Input Locale. Note that

    “French (Canada) – Canadian French” will be installed as the default Input

    Locale once the User Locale is set to 00000c0c (provided step 1 above has

    been followed).

     

    5. Does my thinking make any sense?

    here is the original article whith the explanation of the solution for Fr-CA keyboard.

     

    https://www.pcreview.co.uk/threads/french-canadian-keyboard.1602642/

     

    Avatar
    wullieb1
    Moderator
    #615390

    So what isn’t working?

    Your KeyboardLocale doesn’t need the ” in it.

    It appears that the KeyboardLocale is the same so this might also be causing a problem. Use either fr-CA or 0c0c:00001009

    You also don’t need a space in it.

    Have you also set these in the BootStrap.ini file? It needs to be set there as well according to the documentation.

    KeyboardLocale
    A list of keyboard locales to be used with the target operating system. More than one keyboard locale can be specified for the target operating system. Each locale must be separated by a semicolon (;). If not specified, the Deployment Wizard uses the keyboard locale configured in the image being deployed.
    Exclude this setting in USMT when backing up and restoring user state information. Otherwise, the settings in the user state information will override the values specified in the KeyboardLocale property.

    Note
    For this property to function properly, it must be configured in both CustomSettings.ini and BootStrap.ini. BootStrap.ini is processed before a deployment share (which contains CustomSettings.ini) has been selected.

    • This reply was modified 7 months, 1 week ago by Avatar wullieb1.
    Avatar
    wullieb1
    Moderator
    #615546

    Sorry i did respond to this but its disappeared.

    I’m grabbing both a French Windows 10 Install disk as well as a French Canadian Windows 10 Installation disk to try and see if i can replicate what you’re trying to do via MDT.

    Can you please let me know what it is that isn’t working? There is obviously something that isn’t right when you install so what is it? Is it the UILanguage that is wrong, is it the KeyboardLocale that’s wrong, is it the UserLocal thats wrong or is it the InputLocale that is wrong?

    A French/French Canadian disk should install by default with French as the language. I would assume that French Canadian would do the same.

    Avatar
    wullieb1
    Moderator
    #615562

    So I’ve downloaded the 2 ISO’s mentioned, FR-FR and FR-CA, and imported them into a DS with nothing set as the locale. This is a base installation with zero changes made to the TS, CustomSettings or Bootstrap.

    As i suspected they both installed as per the languages that the ISO represent so FR-FR installs French and FR-CA installs French Canadian.

    From your first post the issue appears to be that the keyboard locale is incorrect, shows as French Multilingual when it should be Canadian French and the inputlocale needs to be French Canada.

    IMHO the easiest thing would be to get a French Canadian Windows 10 Installation disk and use that as it appears to install the language and keyboard that you require.

    If you really need to use the FR-FR disk then i believe these are the settings that you will require in your customsettings.ini file:

    InputLocale=fr-CA

    SystemLocale=fr-CA

    UserLocale=fr-CA

    KeyboardLocale=fr-CA

    UILanguage=fr-CA

    I also think you will need an active internet connection as the install that i completed installed the relevant language packs from windows update.

    Avatar
    mla
    Participant
    #615598

    Hi,

    first I appreciate your time. Strange I saw your second reply in my e-mail notif, but did not find it on actual tread…

    So, I keep your notes and suggestions as a second step to try.

    I am really surprised that you pointed to W10 French Canadian source. I was sure, I never saw it. It was English or French.

    For fun I logged in to MS Licensing portal… and my jaw just dropped down… Yes there is French Canadian in language selection.

    I guess it started with Windows 10. I think for W7 there was only French ISO.

    So I am installing a new VM for capture. Will bring an update. May be it will do the trick without any additional efforts when deploying.

    From the other hand during Capture sysprep screws up every manual setting (at least language related) then CS.ini should be adjusted…

    We’ll see with the new installation source.

    Thanks again.

     

    Avatar
    wullieb1
    Moderator
    #615759

    We’re moving out of the scope of the question but i usually have my build and capture MDT server separate from my production server.

    Head over to Deployment Research and you’ll get all the help you can from there.

    Avatar
    mla
    Participant
    #615810

    I am on vacation… Didn’t have time to respond. I tried 2 deployments using image of fr ca. Didn’t get positive result using CS language as you recommended and without. Sure that installation from the ft ca iso was with right result. Will try again on return.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.