Maybe a tough one…

Home Forums Virtualization Microsoft Hyper-V Technology Maybe a tough one…

This topic contains 5 replies, has 4 voices, and was last updated by tehcamel tehcamel 7 years, 1 month ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • Avatar
    shmengie
    Member
    #159988

    Hi there:

    I’ve got an HP GL370 with 5 physical NICs running 2K8 R2. I’ve installed Hyper-V and have set up several VMs without issue. All these VMs share the same virtual and physical NICs because they’re all on the network. So far, so good. So…

    I have set up a new VM (W7, just for light-duty code compiling, but needs to talk to an outside host) in the DMZ. I created a new virtual NIC, and mapped that to it’s own, separate physical NIC. This is where the trouble begins…

    The host box (the 2K8 install), has some code on it that needs to talk to another box on the domain. It does that just fine, until I enable the NIC that’s in the DMZ. Then, I can’t get to the other box. Can’t ping it; nothing. It’s like the DMZ’d NIC is superceding the network NIC.

    It’s possible (likely?) that there’s a tick box or radio button that I’ve overlooked, or don’t understand.

    I know it’s tough from here, but can anyone advise on how these two networks can peacefully co-exist?

    Thanks!!

    Avatar
    Ossian
    Moderator
    #187437

    Re: Maybe a tough one…

    Can you post more information, starting with IPCONFIG/ALL from all relevant networks?

    Avatar
    Lior_S
    Member
    #282974

    Re: Maybe a tough one…

    You may need to adjust your NIC binding order
    if you go to Control PanelNetwork and InternetNetwork Connections

    Then AdvancedAdvanced Settings
    Move up (or down) the NICS in order they should be accessed. Not sure if it applies but is something to check.

    Also see here for general info.
    http://support.microsoft.com/kb/894564

    Avatar
    shmengie
    Member
    #247218

    Re: Maybe a tough one…

    Thanks, both of you. I wound up out of the office today. I’ll check this stuff tomorrow.

    Thanks again!

    tehcamel
    tehcamel
    Moderator
    #359092

    Re: Maybe a tough one…

    also make sure you don’t have multiple gateways..

    Avatar
    shmengie
    Member
    #247219

    Re: Maybe a tough one…

    I’d like to thank everyone for their input. In the end, it was the multiple gateway thing, so a little bit of extra thanks to tehcamel.

    I love this place!!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.