ipconfig shows correct DNS settings, but DNS not working

Home Forums Microsoft Networking and Management Services DNS ipconfig shows correct DNS settings, but DNS not working

This topic contains 3 replies, has 3 voices, and was last updated by JeremyW JeremyW 4 years, 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • Avatar
    shmengie
    Member
    #165360

    Man, what a pain…

    I’m visiting our UK office from the states. I installed a firewall with site-to-site back to the states. All network resources are available to my on my laptop, but the UK users still need to run the VPN client to access the US resources. From a UK machine I can ping US servers by IP or FQDN, but not by name. Here’s what I’ve done/tried:

    flush/register DNS. Hard code DNS. Added the domain suffix to the firewall. Disable/re-enable the adapter.

    The only difference I can think of between my laptop and theirs is that mine is domained.

    These are all W7 64 boxes. Can some smart person help me out here? I got about 2 hours before I have to catch a train…

    Thanks!

    JeremyW
    JeremyW
    Moderator
    #271212
    shmengie;n490432 wrote:
    From a UK machine I can ping US servers by IP or FQDN, but not by name.

    If the UK computers are not in the same domain then this is to be expected. When you use just the hostname and not the FQDN, the computer does a few things to find out what you’re wanting to contact:
    – It will append any DNS suffixes it has in the adapter and system’s list to the name and perform a DNS lookup with the relative FQDN
    – It uses NETBIOS to see if there are any hosts on the local subnet that have that name

    If the UK computers are in their own domain you can use group policy to deploy the US DNS suffix to those computers and then they’ll be able to use just the name.
    The reason the VPN client works is most likely it adds the proper DNS suffix to the VPN interface on the client.

    shmengie;n490432 wrote:
    Added the domain suffix to the firewall.

    This will just enable the firewall to lookup by name, not the clients.

    Hope that helps…. but not before you’re on that train I’m afraid. ;)

    Avatar
    biggles77
    Spectator
    #213830

    Have you looked in the DNS Server to see if there is an A Record for the name? (Assuming Jeremy’s suggestion didn’t resolve the issue)

    Avatar
    shmengie
    Member
    #247229

    Thanks, Jeremy! I assumed the clients would get the suffix from the firewall. I Teamviewered in and added the suffix to their connections and they’re all good now. Thanks again! And thanks biggles for jumping in; never hurts to extra eyes on stuff!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.