How do I increase the VSS timeout?

Home Forums Server Operating Systems SBS 2000 / 2003 / 2008 / 2011 How do I increase the VSS timeout?

This topic contains 3 replies, has 4 voices, and was last updated by Avatar Dext 6 years, 3 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • Avatar
    5habbaranks
    Participant
    #162165

    Hi,

    Ive been battling with backups and VSS writer timeouts for 2 years now, with inconsistent problems. Sometimes backups are successful and other times not. Im being led to believe that because of the server setup and the drive raidsize this is possibly causing VSS to time out.

    Im currently using BE2012 but also trialling Backup Assist. Within backup assist there is an option to increase the VSS timeout from default 10 minutes to what ever.

    Am I correct in thinking its possible to do this via a registry key within sbs2008? The reason I ask is, if this fixes the backup issues with the vss writers timing out, then there wont be a need to change the backup solution.

    Any ideas guys?

    Avatar
    Ossian
    Moderator
    #188780

    Re: How do I increase the VSS timeout?

    According to a very helpful web site called :google: it involves a registry key:
    https://www.google.co.uk/search?q=increase+the+VSS+timeout&sourceid=ie7&rls=com.microsoft:en-GB:IE-Address&ie=&oe=&gws_rd=cr&ei=gtUNUoD_GO-S0QWG_oDIBA

    As always, be careful before editing the registry.

    Did you actually do any research before posting — it took me longer to type up this post than to find the information you asked :evil:

    Avatar
    Dext
    Member
    #379028

    Re: How do I increase the VSS timeout?

    Ossian;276098 wrote:
    According to a very helpful web site called :google: it involves a registry key:
    https://www.google.co.uk/search?q=increase+the+VSS+timeout&sourceid=ie7&rls=com.microsoft:en-GB:IE-Address&ie=&oe=&gws_rd=cr&ei=gtUNUoD_GO-S0QWG_oDIBA

    As always, be careful before editing the registry.

    Did you actually do any research before posting — it took me longer to type up this post than to find the information you asked :evil:

    I did research and it took me to the exact links you linked me to. The reason I questioned it was that all the links I found was related to Vaeem. Which obviously isn’t the case for me.

    Also I was raising the question not just asking for links, so if others have had the same issue and overcome it by the VSS timeout modification then I would hope they post this.

    But thanks for your google link :)

    If anyone does need the registry location its

    HKLMSoftware\MicrosoftWindows NTCurrentVersionSPPCreateTimeout

    and set to 1200000 which is 20 minutes.

    If this isn’t present, you’ll need to manually enter the registry key. It’s a DWORD 32-bit key.

    Avatar
    LSainsbury
    Member
    #308856

    Re: How do I increase the VSS timeout?

    5habbaranks;276102 wrote:
    I did research and it took me to the exact links you linked me to. The reason I questioned it was that all the links I found was related to Vaeem. Which obviously isn’t the case for me.

    Regardless of the end product, if it’s using the VSS service then it should apply – as you are using the VSS service. 8-)

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.