FTP access from Windows/Internet Explorer

Home Forums Client Operating Systems Windows 10 FTP access from Windows/Internet Explorer

This topic contains 18 replies, has 5 voices, and was last updated by  Jo Ann 9 months, 1 week ago.

Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts

  • KodiaK
    Member
    #166983

    I have an external HDD drive attached to the router Asus RT-N18U and have it configured as a FTP Share. The problem is i can only access this ftp from Chrome Browser.
    If i try from IE i get “This page can’t be displayed” error, and from Windows Explorer i get the attached error.
    In Internet Options I have enabled “Enable FTP folder view” and “Use passive FTP” options.

    Can anyone help me out?

    Blood
    Blood
    Moderator
    #337276

    Does the Asus RT-N18U have a web interface where you can configure access to the (USB) external drive? I would go through the settings and make sure that network access is properly configured.


    Adalberto
    Member
    #386778

    Yes, it has a web interface. That is where i configured the USB HDD as a FTP share. I think that everything is configured properly there, since the i can access the ftp from Chrome without any issues.
    I believe the problem is somewhere within IE settings, but i can’t figure out where :(

    Blood
    Blood
    Moderator
    #337278

    Have you tried resetting IE, and/or running it with no add-ons? Can you access other FTP sites using I.E.?


    Adalberto
    Member
    #386779

    Good point :)
    Haven’t thought of trying this. I tried now and they work. So what could be the problem?


    Ossian
    Moderator
    #191639

    What worked (Reset IE or No Addons)?
    Basically, turn settings on one by one until failure


    Adalberto
    Member
    #386780

    Other ftp sites worked from IE and Windows Explorer. I don’t use IE at all, so nothing to reset, it’s as default as can be :)

    Blood
    Blood
    Moderator
    #337280

    Deleted this response.

    Blood
    Blood
    Moderator
    #337281

    Have you made sure the router is using the latest firmware – it was last updated 24th April. Have you also gone through the manual’s instructions for setting up FTP access – check to make sure everything is properly configured.

    https://www.asus.com/Networking/RTN18U/HelpDesk_Download/


    Adalberto
    Member
    #386781

    Yes, router is on latest firmware. I am pretty sure the FTP access is set up properly. I think the problem may be with the access to Asus DDNS from IE/Windows Explorer. The link is in the format [url]ftp://[myname].asuscomm.com[/url]. I also tried to access the ftp using the IP address and it also woks only from chrome.
    Unfortunately i don’t have any advanced network knowledge, so maybe someone can point out what maybe the issue here.

    Blood
    Blood
    Moderator
    #337284

    Which version of I.E. are you using?

    Blood
    Blood
    Moderator
    #337285

    Finally – I used to be a staunch supporter of I.E. over Chrome in years past. However, Chrome has overtaken it. I have found that sites do not render properly, or simply do not load (the same with Edge). Is there a compelling reason for you to use I.E.? Also, if other FTP sites work, I really would double-check the settings on the router and if they are correct, contact ASUS support. If you find a solution – please post back with the response.


    Adalberto
    Member
    #386782

    I am using IE 11, but this is not that relevant. I am not really interested in access from IE, but from Windows Explorer.
    I would like some people to have access to the ftp share via a folder like shortcut. I mentioned the IE access problem because i thought that it might be related to windows explorer access issue.
    In the meantime i tested the access through Chrome from different computers outside my LAN and it worked in all cases. At the same time the access from IE or Windows Explorer did not work on any of them.
    I was hoping that maybe someone else here has set up a ftp share through ASUS and maybe has some insight. I think the next step is to contact asus support.

    Blood
    Blood
    Moderator
    #337290

    When you mentioned above that you also tried using ftp:// did you use the LAN address – e.g. 192.168.1.1 or whatever it may be, as opposed to a publicly routable IP address?


    Adalberto
    Member
    #386783

    I tried both IPs. Neither work from IE/Windows Explorer; both work from Chrome.


    Adalberto
    Member
    #386784

    I got a response from Asus. Seems that what i want is not possible. They suggested replacing ftp with https for a secure connection to the router. After i did this i was able to access the HDD attached to the router from IE, but through the AiCloud Asus application and not like a classical ftp share.
    But obviously if i try to access [url]https://[myname].asuscomm.com[/url] from Windows Explorer i can’t :(

    Blood
    Blood
    Moderator
    #337291

    Perhaps this is something they can add to a ‘suggestions list’. Still, at least you can now access it locally via both Chrome and I.E.


    Adalberto
    Member
    #386785

    I’m sure they won’t :)
    Locally i can access it via windows explorer like a normal folder :) It would have been nice though that others could access it like this from outside my network.
    Thanks anyways for all the help ;)


    Jo Ann
    Member
    #391971

    [USER=”89392″]KodiaK[/USER]
    I just created an account on this forum to help you (and any other googlers who end up here) out. Turns out the whole thing is actually quite simple.

    Rather than putting “ftp://192.168.x.x” in your windows explorer address bar, what you need to do is put “ftp://username:[email protected]” where the whole thing is to be put without inverted commas and replace 192.168.x.x is your router’s gateway and username and password with the ones mentioned on your Asus Router’s FTP share page. They are generally the same as your Router’s default login password and default username unless you changed it.

Viewing 19 posts - 1 through 19 (of 19 total)

You must be logged in to reply to this topic.