Exchange Issues – DNS

Home Forums Microsoft Networking and Management Services DNS Exchange Issues – DNS

This topic contains 8 replies, has 2 voices, and was last updated by Avatar Si_Pe 5 years, 7 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • Avatar
    Si_Pe
    Member
    #163282

    Hello,

    All I have a strange issue that has appeared this afternoon.

    I am running windows 2000 Advance server with Exchange 2003 (we are just in discussions about migrating to the cloud)

    When trying to open system administrator I am getting an error message with an ID of – c007054b which looks like it points to a dns issue. I have ran a netdiag on the email box and it’s coming back with a couple of errors. 1st is Kerberos test – FATAL – Kerberos does not have a ticket for “server1”

    Also getting two LDAP test errors – Warning – Failed to query SPN registration on DC “server2”

    I believe some work on dns forwarders was done over the weekend, all the info I have is a zone was remove to be able to add a couple of forwarders.

    http://support.microsoft.com/kb/229840

    Since this has been done the only way I can get into the System manager is to add the exchange servers own ip as the primary dns entry.

    I can assume something needed has been remove from DNS zone? I am not that clued up on DNS so if anyone can help that would be great.

    Many thanks!

    JeremyW
    JeremyW
    Moderator
    #270868

    Re: Exchange Issues – DNS

    How many DNS servers do you have?
    What zones are there?
    What zone was deleted?
    What server is the Exchange box using for DNS?

    If DNS works when you point the Exchange server to itself then it sounds like it’s at least running DNS services. It’s probably also a DC.

    Can you post an IPCONFIG /ALL from any DNS servers and your Exchange server?

    Avatar
    Si_Pe
    Member
    #278275

    Re: Exchange Issues – DNS

    Hello,

    Thanks for replying!

    The zone that was deleted was the “.” zone which according to Microsoft stops the editing of the forwarders as its grayed out. Support link which I think was followed.

    We have two DNS servers, the exchange server is using both of them for DNS.

    The exchange server isn’t a DC and it hasn’t got any DNS services running apart from the client one.

    Here are the IPCONFIG from all.

    DNS 1

    Email Server

    DNS Server 1 Ipconfig

    DNS Server 2

    Both the DNS servers are running windows 2008

    Many thanks,

    JeremyW
    JeremyW
    Moderator
    #270874

    Re: Exchange Issues – DNS

    So does everything “work” on the Exchange server when you have it pointed to itself for DNS?

    I can tell you that if you do not have DNS server installed on the Exchange server, when it queries itself for DNS it will fail and then move on to the next server which is .6. So I would check to make sure DNS is working correctly on .5 and has the proper information.

    Is .5 a DC? Is the DNS AD integrated?

    Avatar
    Si_Pe
    Member
    #278276

    Re: Exchange Issues – DNS

    Hello,

    Yes everything works when it’s pointing to itself. Should I setup the exchange server as a DNS server?

    What checks do you suggest I do on .5?

    .5 is a DC and it’s integrated.

    Many thanks for your help!

    JeremyW
    JeremyW
    Moderator
    #270875

    Re: Exchange Issues – DNS

    Si_Pe;281805 wrote:
    Yes everything works when it’s pointing to itself. Should I setup the exchange server as a DNS server?

    If DNS is not setup, then it’s really just using the secondary, which is .6. So that tells me that .6 is working and .5 is not.

    Si_Pe;281805 wrote:
    What checks do you suggest I do on .5?

    .5 is a DC and it’s integrated.

    Compare the zone files on .5 and .6.
    Run dcdiag on .5 and .6
    Check AD replication
    Check the event logs on the servers, including DFS, DNS, FRS, and Directory Services on the DCs. Look for any issues that need to be resolved.

    Avatar
    Si_Pe
    Member
    #278277

    Re: Exchange Issues – DNS

    Thanks again!

    I am getting the below error in the logs

    The DNS server encountered error 32 attempting to load zone . from Active Directory. The DNS server will attempt to load this zone again on the next timeout cycle. This can be caused by high Active Directory load and may be a transient condition.

    And below is the next event in the log.

    The DNS server received indication that zone cad was deleted from the Active Directory. Since this zone was an Active Directory integrated zone, it has been deleted from the DNS server.

    I haven’t looked at it yet but guessing it can’t be good!

    Thanks!

    JeremyW
    JeremyW
    Moderator
    #270877

    Re: Exchange Issues – DNS

    Go ahead and finish checking the rest of the logs, compare the DNS zones, and run the dcdiag on the DCs.

    Avatar
    Si_Pe
    Member
    #278278

    Re: Exchange Issues – DNS

    Hello,

    You were correct, it seems there is an issue with the .5 server as I have pointed the exchange server to the .6 and all appears well. I am going to continue looking at the logs on the dc’s and dns boxes.

    Many thanks for your help!

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.