Exchange 2007 not working after RAID failure…….

Home Forums Messaging Software Exchange 2007 / 2010 / 2013 Exchange 2007 not working after RAID failure…….

This topic contains 1 reply, has 2 voices, and was last updated by  mkarmel 7 months, 4 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts

  • markymahyem1
    Member
    #167498

    hello all.
    Had a RAID 5 drive failure on a Windows SBS 2008 server running exchange 2007
    Ended up with the mailbox db not mounting, with checksum error.
    ran eseutil /mh on the database, results below. showed clean shutdown and a checksum error
    moved the log files, and the database mounted, but was not working – no inbound or outbound email.
    I shut down the services and am running eseutil /k right now
    one thing I noticed – I think somehow the server reverted to using an old, expired ssl for our old domain somehow…. not sure how/why that may have happened
    see the log file below, and please, any assistance would be very very much appreciated.

    C:Program FilesMicrosoftExchange ServerBin>eseutil /mh “d:Exchange Database
    sMailbox Database.edb”

    Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
    Version 08.03
    Copyright (C) Microsoft Corporation. All Rights Reserved.

    Initiating FILE DUMP mode…
    Database: d:Exchange DatabasesMailbox Database.edb

    File Type: Database
    Format ulMagic: 0x89abcdef
    Engine ulMagic: 0x89abcdef
    Format ulVersion: 0x620,12
    Engine ulVersion: 0x620,12
    Created ulVersion: 0x620,12
    DB Signature: Create time:10/12/2010 15:56:43 Rand:2863176 Computer:
    cbDbPage: 8192
    dbtime: 971030624 (0x39e0c060)
    State: Clean Shutdown
    Log Required: 0-0 (0x0-0x0)
    Log Committed: 0-0 (0x0-0x0)
    Streaming File: No
    Shadowed: Yes
    Last Objid: 213400
    Scrub Dbtime: 0 (0x0)
    Scrub Date: 00/00/1900 00:00:00
    Repair Count: 0
    Repair Date: 00/00/1900 00:00:00
    Old Repair Count: 0
    Last Consistent: (0x978C6,9,1F0) 04/11/2018 12:28:13
    Last Attach: (0x97883,9,86) 04/09/2018 07:10:28
    Last Detach: (0x978C6,9,1F0) 04/11/2018 12:28:13
    Dbid: 1
    Log Signature: Create time:10/12/2010 15:56:43 Rand:2887853 Computer:
    OS Version: (6.0.6002 SP 2 NLS 500100.50100)

    Previous Full Backup:
    Log Gen: 620589-620609 (0x9782d-0x97841) – OSSnapshot
    Mark: (0x97842,8,16)
    Mark: 04/07/2018 19:01:30

    Previous Incremental Backup:
    Log Gen: 0-0 (0x0-0x0)
    Mark: (0x0,0,0)
    Mark: 00/00/1900 00:00:00

    Previous Copy Backup:
    Log Gen: 0-0 (0x0-0x0)
    Mark: (0x0,0,0)
    Mark: 00/00/1900 00:00:00

    Previous Differential Backup:
    Log Gen: 0-0 (0x0-0x0)
    Mark: (0x0,0,0)
    Mark: 00/00/1900 00:00:00

    Current Full Backup:
    Log Gen: 0-0 (0x0-0x0)
    Mark: (0x0,0,0)
    Mark: 00/00/1900 00:00:00

    Current Shadow copy backup:
    Log Gen: 0-0 (0x0-0x0)
    Mark: (0x0,0,0)
    Mark: 00/00/1900 00:00:00

    cpgUpgrade55Format: 0
    cpgUpgradeFreePages: 0
    cpgUpgradeSpaceMapPages: 0

    ECC Fix Success Count: none
    Old ECC Fix Success Count: none
    ECC Fix Error Count: none
    Old ECC Fix Error Count: none
    Bad Checksum Error Count: found (1)
    Last Bad Checksum Error Date: 04/08/2018 02:20:47
    Old bad Checksum Error Count: none

    Operation completed successfully in 0.655 seconds.

    C:Program FilesMicrosoftExchange ServerBin>

    Microsoft Windows [Version 6.0.6002]
    Copyright (c) 2006 Microsoft Corporation. All rights reserved.

    C:UsersAdministrator.steamaticstl>cd

    C:>cd program files

    C:Program Files>cd microsofrt
    The system cannot find the path specified.

    C:Program Files>cd microsoft

    C:Program FilesMicrosoft>cd exchange server

    C:Program FilesMicrosoftExchange Server>cd bin

    C:Program FilesMicrosoftExchange ServerBin>esutil /mh d:Exchange Databases
    Mailbox Database.edb
    ‘esutil’ is not recognized as an internal or external command,
    operable program or batch file.

    C:Program FilesMicrosoftExchange ServerBin>eseutil /mh d:Exchange Databases
    Mailbox Database.edb

    Usage Error: Invalid argument ‘DatabasesMailbox’. Options must be preceded by ‘
    -‘ or ‘/’.

    Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
    Version 08.03
    Copyright (C) Microsoft Corporation. All Rights Reserved.

    DESCRIPTION: Database utilities for the Extensible Storage Engine for Microsoft
    (R) Exchange Server.

    MODES OF OPERATION:
    Defragmentation: ESEUTIL /d [options]
    Recovery: ESEUTIL /r [options]
    Integrity: ESEUTIL /g [options]
    Checksum: ESEUTIL /k [options]
    Repair: ESEUTIL /p [options]
    File Dump: ESEUTIL /m[mode-modifier]
    Copy File: ESEUTIL /y[options]
    Restore: ESEUTIL /c[mode-modifier] [options]

    < <<<< Press a key for more help >>>>>
    D=Defragmentation, R=Recovery, G=inteGrity, K=checKsum,
    P=rePair, M=file duMp, Y=copY file, C=restore
    =>

    C:Program FilesMicrosoftExchange ServerBin>eseutil /mh “d:Exchange Database
    sMailbox Database.edb”

    Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
    Version 08.03
    Copyright (C) Microsoft Corporation. All Rights Reserved.

    Initiating FILE DUMP mode…
    Database: d:Exchange DatabasesMailbox Database.edb

    File Type: Database
    Format ulMagic: 0x89abcdef
    Engine ulMagic: 0x89abcdef
    Format ulVersion: 0x620,12
    Engine ulVersion: 0x620,12
    Created ulVersion: 0x620,12
    DB Signature: Create time:10/12/2010 15:56:43 Rand:2863176 Computer:
    cbDbPage: 8192
    dbtime: 971030624 (0x39e0c060)
    State: Clean Shutdown
    Log Required: 0-0 (0x0-0x0)
    Log Committed: 0-0 (0x0-0x0)
    Streaming File: No
    Shadowed: Yes
    Last Objid: 213400
    Scrub Dbtime: 0 (0x0)
    Scrub Date: 00/00/1900 00:00:00
    Repair Count: 0
    Repair Date: 00/00/1900 00:00:00
    Old Repair Count: 0
    Last Consistent: (0x978C6,9,1F0) 04/11/2018 12:28:13
    Last Attach: (0x97883,9,86) 04/09/2018 07:10:28
    Last Detach: (0x978C6,9,1F0) 04/11/2018 12:28:13
    Dbid: 1
    Log Signature: Create time:10/12/2010 15:56:43 Rand:2887853 Computer:
    OS Version: (6.0.6002 SP 2 NLS 500100.50100)

    Previous Full Backup:
    Log Gen: 620589-620609 (0x9782d-0x97841) – OSSnapshot
    Mark: (0x97842,8,16)
    Mark: 04/07/2018 19:01:30

    Previous Incremental Backup:
    Log Gen: 0-0 (0x0-0x0)
    Mark: (0x0,0,0)
    Mark: 00/00/1900 00:00:00

    Previous Copy Backup:
    Log Gen: 0-0 (0x0-0x0)
    Mark: (0x0,0,0)
    Mark: 00/00/1900 00:00:00

    Previous Differential Backup:
    Log Gen: 0-0 (0x0-0x0)
    Mark: (0x0,0,0)
    Mark: 00/00/1900 00:00:00

    Current Full Backup:
    Log Gen: 0-0 (0x0-0x0)
    Mark: (0x0,0,0)
    Mark: 00/00/1900 00:00:00

    Current Shadow copy backup:
    Log Gen: 0-0 (0x0-0x0)
    Mark: (0x0,0,0)
    Mark: 00/00/1900 00:00:00

    cpgUpgrade55Format: 0
    cpgUpgradeFreePages: 0
    cpgUpgradeSpaceMapPages: 0

    ECC Fix Success Count: none
    Old ECC Fix Success Count: none
    ECC Fix Error Count: none
    Old ECC Fix Error Count: none
    Bad Checksum Error Count: found (1)
    Last Bad Checksum Error Date: 04/08/2018 02:20:47
    Old bad Checksum Error Count: none

    Operation completed successfully in 0.655 seconds.

    C:Program FilesMicrosoftExchange ServerBin>eseutil /k “d:Exchange Databases
    Mailbox Database.edb”


    mkarmel
    Member
    #391747

    After RAID 5 failure , How you fix that Drive?
    Is it same drive environment as old , same formatted and same drive name ? any changes ?
    Have you restore .edb file from offline backup ,third-party software to the same location ?

    Some common notes :
    1) Make sure the store is dismounted. It probably is already.
    2) Perform an offline backup of the EDB, STM, and LOG files (first rule of data recovery is “Do No Further Harm”.)
    3) Run ESEUTIL /D against the database. That might actually fix it. Doubtful, but there is a small chance that the corruption is in the whitespace of the database that is discarded during the /D.
    4) If that does not do it, run ESEUTIL /P against the database
    5) Run ESEUTIL /K again to make sure the corruption is cleared up.
    6) Run isinteg -fix -test alltests against that database. You may need to run it several times until it reports no errors.

    http://www.emaildoctor.org/blog/ulti…eutil-isinteg/

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.