EWS issues – Could not establish trust relationship for the SSL/TLS secure channel.

Home Forums Messaging Software Exchange 2007 / 2010 / 2013 EWS issues – Could not establish trust relationship for the SSL/TLS secure channel.

This topic contains 2 replies, has 3 voices, and was last updated by  vsharma 8 months, 2 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #167485

    Hi,

    First of all, I’m total noob for Exchange services. I have deployed Exchange 2013 in my lab to test one software integration via EWS. All the time, I have “Invalid credentials (401)” error, and I could not troubleshoot in detail. So I downloaded EWSEditor to test connection to my local Exchange server. After testing Exchange services configuration, I’m getting following:

    Message: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.
    Exception details:
    Message: The remote certificate is invalid according to the validation procedure.

    Now, since I don’t have enough skill with Exchange nor CA, what do I need to setup (regarding certificates) on client side so EWS connection would work properly?


    Ossian
    Moderator
    #191967

    Make sure the certificate (or the root CA in the issuing chain) is trusted by the other side. Where did you get the certificate?


    vsharma
    Member
    #391995

    I just opened EWSEditor and made Exchange service. When I specify Service URL (https://exchange.domain.name/EWS/Exchange.asmx) I receive SSL error. On Exchange Admin center, I can see certificates (Microsoft Exchange Server Auth Certificate, Microsoft Exchange, WMSVC) which are all Valid.

    Do you have any suggestion what could I try to test?

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.