Error when trying to remove a Mailbox Database on Exchange Server 2010 SP3

Home Forums Messaging Software Exchange 2007 / 2010 / 2013 Error when trying to remove a Mailbox Database on Exchange Server 2010 SP3

This topic contains 1 reply, has 2 voices, and was last updated by  biggles77 2 months, 1 week ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #167702

    Dear all

    I have run exchange server 2010 SP3 & 2007 in same organization and i got[SIZE=12px] Error when trying to remove a Mailbox Database1 on Exchange Server 2010[/SIZE]

    [SIZE=13px]The full error is:[/SIZE]

    [SIZE=12px]This mailbox database contains one or more mailboxes, mailbox plans, archive mailboxes, public folder mailboxes or arbitration mailboxes, Audit mailboxes. To get a list of all mailboxes in this database, run the command Get-Mailbox -Database . To get a list of all mailbox plans in this database, run the command Get-MailboxPlan. To get a list of archive mailboxes in this database, run the command Get-Mailbox -Database -Archive. To get a list of all public folder mailboxes in this database, run the command Get-Mailbox -Database -PublicFolder. To get a list of all arbitration mailboxes in this database, run the command Get-Mailbox -Database -Arbitration. To get a list of all Audit mailboxes in this database, run the command Get-Mailbox -Database -AuditLog. To disable a non-arbitration mailbox so that you can delete the mailbox database, run the command Disable-Mailbox . To disable an archive mailbox so you can delete the mailbox database, run the command Disable-Mailbox -Archive. To disable a public folder mailbox so that you can delete the mailbox database, run the command Disable-Mailbox -PublicFolder. To disable a Audit mailbox so that you can delete the mailbox database, run the command Get-Mailbox -AuditLog | Disable-Mailbox. Arbitration mailboxes should be moved to another server; to do this, run the command New-MoveRequest . If this is the last server in the organization, run the command Disable-Mailbox -Arbitration -DisableLastArbitrationMailboxAllowed to disable the arbitration mailbox. Mailbox plans should be moved to another server; to do this, run the command Set-MailboxPlan -Database .[/SIZE]

    What was my steps to solve this :

    1- Move all Active mailboxs from MD1 to MD2
    2-Show “hidden” Arbitration mailboxes in Exchange Server 2010 with get-mailbox -Database “DB1” -Arbitration
    2- Move “hidden” Arbitration mailboxes in Exchange Server 2010 with get-mailbox -Database “Mailbox Database 1” -Arbitration | New-MoveRequest –TargetDatabase “MailboxDatabase 2”

    MailboxDatabase 2” Arbitrations show as :

    [SIZE=12px]FederatedEmail.4c1f4d8b-8179-4148-93bf-00a95fa1e042
    SystemMailbox{1f05a927-f7a0-4bff-ba0e-7400efadb1d7}
    SystemMailbox{e0dc1c29-89c3-4034-b678-e6c29d823ed9}[/SIZE]

    3-Now trying to remove Mailbox Database1 again but show the same error !!
    4-Try to set the Mailbox Retention to 0.00:00:00
    5-And show “hidden” ObjectClass

    • I have run Get-MailboxStatistics -Database | ft DisplayName,ObjectClass

    [SIZE=14px][SIZE=14px]Why Get-MailboxStatistics[/SIZE][/SIZE] ?
    Because it show the system mailbox + user mailbox + archive mailbox + deleted mailboxes (mark for deletion) + softly deleted mailboxes (in case of local move request)

    I noticed what looks like system objects with the ObjectClass attribute being

    1- Personal Archive – Discovery Search Mailbox with ObjectClass “Mailbox, UserDisabled”.

    2- SystemMailbox{58d9a488-e06c-46e8-bbb4-a906d5b948c7} (this mailbox’s ObjectClass attribute = “Mailbox, ExOleDbSystemMailbox”).

    [SIZE=14px]Q1>[/SIZE]what are they ?
    [SIZE=14px]Q2>[/SIZE]Shall i force delete them by ExCmdPowrshell & directly in ADSIEdit *
    or there is away to move them to MD2 ?

    _______________________________________

    * Note : Worst case you can delete the database from ADSI.

    How to remove the databases via ADSIEdit:

    Open ADSIEdit.
    Navigate to –> Configuration –>Services –> Microsoft Exchange –> –> Administrative Groups –> Exchange Administrative Groups –> Databases.
    Locate the database and delete it.


    biggles77
    Spectator
    #214480

    Hi Hani, I have enlarged the font size of the block of red text to make it easier to read. Nothing was change except the font size. :-)

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.