Enabling SSL Cert – IIS issues

Home Forums Messaging Software Exchange 2007 / 2010 / 2013 Enabling SSL Cert – IIS issues

This topic contains 6 replies, has 3 voices, and was last updated by  mkarmel 1 year, 8 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #166968

    Enabling SSL Cert has issue with enabling IIS :

    Enable-ExchangeCertificate : An unexpected error occurred while the forms-based authentication settings for path /LM/W3SVC/1 were being modif


    Ossian
    Moderator
    #191615

    Which version and service pack of Exchange?
    What process did you follow to request and install the certificate

    (As long as you do it all via Exchange, there should be no issues)


    mkarmel
    Member
    #391729

    Service Pack 2

    I did renew SSL Cert
    install it >>import it >>enable it with

    Enable-ExchangeCertificate -Thumbpring -Services “SMTP, IMAP, POP, IIS
    i the error
    then i did this Enable-ExchangeCertificate -Thumbpring -Services “SMTP, IMAP, POP, without IIS and worked without any error
    after that

    Enable-ExchangeCertificate -Thumbpring -Services IIS
    I got the error


    Ossian
    Moderator
    #191617

    (sigh) Yes, but which VERSION of Exchange? 2007, 2010,….
    Since you are doing it all in Powershell, I assume you are using 2007, but can you confirm that?

    Do you get any more information about the error?
    Have you checked the IIS logs (and the event logs)?
    Where are you generating the certificate request (and how)?
    Where is the certificate from?


    mkarmel
    Member
    #391730

    2007
    SSL cert from godady
    it was expire and i did renew it
    donload it >>import it >>enable it


    Ossian
    Moderator
    #191618

    Because its Exchange (which can be fussy) I normally create a new certificate request rather than a renewal. You may want to try that.

    Also what about the event logs (and perhaps add a few more words to your answers – they don’t actually cost anything)


    mkarmel
    Member
    #391731

    Hello Ossian
    as you know when i did this comd Enable-ExchangeCertificate -Thumbpring -Services IIS i got error (
    Enable-ExchangeCertificate : An unexpected error occurred while the forms-based authentication settings for path /LM/W3SVC/1 were being modif )

    to solve this i added the cert to IIS
    by this way iis manager >>Sites>>Defult Web Stie >> Binding >>https 443 >>link to FQN

    everything is ok

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.