Clients show up wrongly in Network Neighborhood

Home Forums Client Operating Systems Windows 2000 Pro, XP Pro Clients show up wrongly in Network Neighborhood

This topic contains 8 replies, has 4 voices, and was last updated by  rvalstar 11 years, 10 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts

  • danielp
    Member
    #120256

    Hi,

    Quick question, I couldn’t find a solution to it:

    1200 client computers, all XP SP2. Many computers have a description in their System Properties > Computer Name tab. Most computers do not have it. Network is Win2003 AD-based.

    When looking at Network Neighborhood, most computers show up with their computer names. However any computer that has a description is shown like this:

    Computername
    Computername
    (Description) Computername
    Computername
    Computername

    This is simply annoying. Removing the description fixes it, but I would like to keep the description. It’s worth knowing that most computers are image-based, made from one parent Ghost image (done properly, sysprep and all).

    Anyone know why this happens and what can be done to correct it?


    wullieb1
    Participant
    #239984

    Re: Clients show up wrongly in Network Neighborhood

    This is probably way off track for what your looking for but i can select how my ADUC displays this by going to View then Add/Remove Columns then either moving them up or down as needed.

    Sorry that was way off track.

    After having a look under Network Neighbourhood there is an option that basically does the same thing.

    Go to View, Choose Details and in here you can move the details as you please.


    rvalstar
    Member
    #286631

    Re: Clients show up wrongly in Network Neighborhood

    In Windows Explorer, you can specify Details (columns) to view (only Name and Comment are available). Comment is the “Description” but Name becomes “Description (ComputerName)” for a non-blank “Description”. That is just annoying.

    Only thing I can think of to fix this cute little Bob-like feature is to blank out the description or prefix it with ComputerName. The value is here:

    Quote:
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServiceslanmanserverparameters]
    “srvcomment”=”Annoying Description”

    Tried putting “%COMPUTERNAME% – ” at the front but it does not get resolved.

    If I wanted a “cute” computer, I would have bought a Mac!!!

    So unless someone out there has a better answer, you have 3 choices:

    1) Live with it

    2) Blank out the description by playing a .REG file setting “srvcomment”=””

    3) Making a VBS to change “Annoying Description” to “%COMPUTERNAME% – Annoying Description” and living with Network Neighborhood showing “%COMPUTERNAME% – Annoying Description (%COMPUTERNAME%)”


    JeremyW
    Moderator
    #268617

    Re: Clients show up wrongly in Network Neighborhood

    Um… http://support.microsoft.com/default.aspx?scid=kb;en-us;330193

    Apparently there was a patch for this included in sp2 but you need to modify the registry to activate it.


    rvalstar
    Member
    #286635

    Re: Clients show up wrongly in Network Neighborhood

    To paraphrase Wayne and Garth:

    “I’m not worthy”

    :beer:

    We need a vino icon as this beer bit doesn’t work for me ;-)


    danielp
    Member
    #170525

    Re: Clients show up wrongly in Network Neighborhood

    JeremyW;53717 wrote:
    Um… http://support.microsoft.com/default.aspx?scid=kb;en-us;330193

    Apparently there was a patch for this included in sp2 but you need to modify the registry to activate it.

    That was it! Thanks man!


    JeremyW
    Moderator
    #268620

    Re: Clients show up wrongly in Network Neighborhood

    No problemo


    rvalstar
    Member
    #286639

    Re: Clients show up wrongly in Network Neighborhood

    So I merged the following REG file to both WXP and W2K3 and both worked without reboot or logoff (may have to exit and re-run Windows Explorer):

    Quote:
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionpoliciesExplorer]
    “ToggleCommentPosition”=dword:00000001

    Now the machine displays as %COMPUTERNAME% (Description).

    I did not try it for HKCU as I want to make sure all users, not just domain users, see the fix.

    NOTE to Designer of this Web Site Software: You have a bug. There is no space in “Current” yet it displays as “Curr ent”


    danielp
    Member
    #170528

    Re: Clients show up wrongly in Network Neighborhood

    Nice! Thanks.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.