cant format my hard disk

Home Forums Client Operating Systems Windows 2000 Pro, XP Pro cant format my hard disk

This topic contains 4 replies, has 5 voices, and was last updated by Avatar baronvonfoxbat7734 15 years, 2 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • Avatar
    bendi
    Member
    #99496

    Hi,
    I am trying to format my hard disk (win 95) with fdisk but i keep getting the message: “cannot write to partition tables format will be terminated”
    i tried fdisk/mbr but received the message “error reading fixed disk”
    i tried resizing the partitions including making only one partition and then ran fdisk but with no results.
    i also ran scan-disk and defrag but nothing helped.
    Anybody got other ideas?
    Thanks,
    bendi

    Avatar
    ahinson
    Member
    #215244

    Re: cant format my hard disk

    bendi wrote:
    “error reading fixed disk”

    That’s not a good error… It could mean the drive, cable, or controller is bad. The first thing I’d do is reseat the drive cables and if it still doesn’t work run the drive manufacturer’s diagnostic utility.

    You will need to know: What brand of drive is it and the capacity.

    The utilities are used for drive testing by the manufacturer to determine if the drive should be RMA’d in the troubleshooting process. If the drive is out of warranty RMA is out of the question but on the up side some utils can repair errors. Also, you can usually write 0’s to the drive’s data area even if it can’t repair the error and then reformat the disk and attempt to use it – it may work even after an unfixable error.

    Good luck.

    Avatar
    stevem5000
    Member
    #217303

    Try the idea of writing “0”‘s to the HD…you can do this by taking any program that “wipes” your hd clean of all info…such as a prog called “Wipe Info”…google for “wipe harddrive” and you will get many h its of things that can do this…

    this usually done with a boot floppy and then running the program that wipes the hd…

    After that, ifg you are going to reinstall W95, the you should be able to go thru the normal fdisk and format process…

    If this doesn’t work, chances are you have a bad HD…the hd mfg disk utility might be able to help, but with the cost of hsd’s being as low as they are, I would just put in a new hd…

    Hope this helps
    Steve

    Avatar
    pclinc
    Member
    #202279

    Delpart work great too.

    #218623

    I have seen this on proprietary systems in the past. Sometimes a manufacturer will punch a hole in the IDE cable to prvent the drive from being formatted. yYou can do with the drive as wish but you will not be able to format it. Try replacing the IDE cable and see if that works. If not, look for a missing pin (not the standard IDE orientation missing pin). If there is a second missing pin, the only answer is a controller card or a new mobo…

    See if this advice helps in your format situation and let us know.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.