Cannot receive mail from exchange 2003 -> Exchange 2007

Home Forums Messaging Software Exchange 2000 / 2003 Cannot receive mail from exchange 2003 -> Exchange 2007

This topic contains 4 replies, has 3 voices, and was last updated by  Craig_Han 9 years, 11 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts

  • Craig_Han
    Member
    #137232

    Hi,

    I have just installed exchange 2007 into our existing exchange 2003 environment (standard install) using this guide http://www.msexchange.org/tutorials/…007-Part1.html

    During the exchange 2007 install, I selected my exchange 2003 server in the Mail Flow Settings part of the wizard. I have moved two test mailboxes from exchange 2003 to 2007 for testing purposes.

    I can from a 2003 mailbox:
    – send to external address
    – send to internal (2003 mailbox)
    – receive internal mail from (2003 mailbox)
    – receive internal mail from (2007 mailbox)
    – receive external mail

    I can from 2007 mailbox:
    – send to external address
    – send to internal (2003 mailbox)
    – send to internal (2007 mailbox)
    – receive internal mail from (2007 mailbox)

    My issue is:

    – sending from 2003 mailbox to 2007 mailbox
    – external to 2007 Mailbox.

    When I send from 2003 mailbox to 2007 mailbox and external to 2007 Mailbox the mail items get stuck in the exchange 2003 administrative group -> SVR2003-SVR2007 (Routing Group Connector). When i look at that queue in Exchange System Manager sometimes it says ‘The connection was dropped by the remote host’ and i can see all the stuck mail items in that queue.I have tried to play around modifying / adding connectors and routing groups. This is hard to test as our mail servers are production and are used a lot 24 / 7. I do not want to cause all my mail to queue.

    Our firewall is nating incoming SMTP traffic to the exchange 2003 server and the exchange 2003 server default SMTP connector is forwarding all mail to an external smart host. (Tried removing this smart host on this connector and use DNS, but no good).

    Things I have done are:
    – Enabled the Anonymous Users enabled on the Default Hub Transport Receiver.
    – Used script to create new Routing Group Connectors.

    Does anyone have any ideas about my issue. Sorry about the lengthy info, just want to cover as much as possible. Any advise would be appreciated.

    Thanks Craig


    AndyJG247
    Member
    #321889

    Re: Cannot receive mail from exchange 2003 -> Exchange 2007

    Firstly, please don’t double post. The forum rules are quite clear on that. Secondly, the internet connector can have a smarthost however can you check the SMTP virtual server for one as you will need to remove it.


    g00ner
    Member
    #346575

    Re: Cannot receive mail from exchange 2003 -> Exchange 2007

    Have you tried running the Exchange Best Practices Analyser?
    http://technet.microsoft.com/en-us/exchange/bb288481.aspx


    Craig_Han
    Member
    #348882

    Re: Cannot receive mail from exchange 2003 -> Exchange 2007

    Hi,

    Firstly sorry about the double post Andy.

    Andy thank you very much as my smtp virtual server had a smart host entry there. Once removed i can now send mail in all dircetions.

    My problem has been resolved.

    Thanks for your reply to G00ner.

    Cheers

    Craig


    AndyJG247
    Member
    #321892

    Re: Cannot receive mail from exchange 2003 -> Exchange 2007

    No problem

    Glad you sorted and thanks for posting back :)

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.