Cannot assign IP address to server core

Home Forums Virtualization Virtual Server & Virtual PC Cannot assign IP address to server core

This topic contains 2 replies, has 3 voices, and was last updated by tehcamel tehcamel 9 years, 8 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • Avatar

    I am trying to use Windows (7) VPC with 2 VMs – one Windows Server 2008 Server Core Ent. x86 and the other Windows Server 2008 Server Ent. x86 configured as a DHCP server.

    Both of the VMs are configured for Internal Network. Both servers are in a workgroup. Static IPs were assigned to both and I could get them to ping each other until after I changed the firewall settings on the Server Core (per one of Petri’s articles).

    I still cannot get the DHCP server to assign the Server Core an IP address.

    This is not for a production environment, but for a learning envirionment.

    I have also tried to do this in VirtualBox and Hyper-V with the same result so I am inclined to think there is something that I need to do in server core to allow it to get an IP address from the DHCP server. I cannot figure out what.

    Any input will be appreciated.


    Re: Cannot assign IP address to server core

    Have you set the Core to get a dynamic IP Address?
    Is the DHCP Role on the Ent. up and running?
    You mentioned that the machines did see each other until you did something. They do not, after this change? Have you reverted the change, to be sure they see each other with static IPs?
    Is the Ent. server IP address part of the scope of the DHCP you defined?


    Re: Cannot assign IP address to server core

    check what firewall settings you applied to each host.
    It’s possible the dhcp server is configured to block dhcp, and it’s possible the dhcp client is configured to now allow DHCP

    It’s a bit harder to do on the core server. You could try turning off the firewall all together, just to be sure dhcp is actually working…

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.