"Append These DNS Suffixes" – Incorrect Entries

Home Forums Client Operating Systems Windows 10 "Append These DNS Suffixes" – Incorrect Entries

This topic contains 0 replies, has 1 voice, and was last updated by Avatar Robert R. 2 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Avatar
    Robert R.
    Participant
    #623604

    01) Operating System = Windows 10 v 1809 Enterprise.

    02) VPN client = Pulse Secure v 9

    03) The laptop is a company owned and configured asset, not a personal/consumer PC.

    04) A user has incorrect entries for Network Connections –> Ethernet –> Ethernet Properties –> TCP/IPv4 Properties –> Advanced TCP/IP Settings –> DNS –> Append these DNS suffixes (in order).

    05) The entries should be

    us.company.com
    domain-01.us.company.com
    domain-02.us.company.com
    domain-03.us.company.com …

    06) Instead, the entries before VPN connection are

    us.
    domain-01.us.company.com
    domain-02.us.company.com …

    or

    us.
    us.
    us.
    domain-01.us.company.com …

    07) After VPN connection the entries are

    company.com (no “us.” prefix)
    us.
    domain-01.us.company.com
    domain-02.us.company.com …

    or

    company.com
    us.
    us.
    us.
    domain-01.us.company.com …

    08) In the registry

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

    Domain REG_SZ us.company.com

    SearchList REG_SZ us.company.com, domain-01.us.company.com, domain-02.us.company.com,

    SearchListAddon REG_SZ company.com

    09) I have changed the value of SearchListAddon back to us.company.com , but something keeps changing it back to company.com

    10) I cannot find any cause for the us. entries

    11) If I run

    wmic /node: COMPUTERNAME nicconfig get DNSDomainSuffixSearchOrder /all

    the results are what they should be, not what they actually are.

    12) Any suggestions on what else I should be looking for?

    Thanks.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.