An ISCSI Connection Disk1 File System: Unknown (BitLocker Encrypted)

Home Forums Virtualization Other Virtualization Products and Issues An ISCSI Connection Disk1 File System: Unknown (BitLocker Encrypted)

This topic contains 1 reply, has 1 voice, and was last updated by  Kobe 310 1 month, 4 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts

  • Kobe 310
    Member
    #167713

    Not sure were to put this question, so i did a search for ISCSI and a question showed up in this section, so i figured i would post this here.

    I’m using a windows 7 VM(VMWare), to run Veeam to back up my vm’s. i have been doing backups to 1 of my SAN’S(Equallogic PS4100) successfully for 3 years. Today i lost my SCSI connections. When i was able to get it connected again, it immediately said “You need to format the disk in drive F before you can use it. I found out that in Disk Management the drive says, 1024
    GB Unknown (Bitlocker Encrypted) Healthy Active Partition…………..However, if i use a different computer to connect to the same SAN Volume, i can connect and access the folder and files. i did notice that the computer that will connect, it’s C: says NTFS (Bitlocker Encrypted)

    -i’m not positive if this timeline is accurate, but i remember being unable to connect the VM in question to the SAN, (SO I THINK,NOT FOR SURE) that i then tried (he computer that works), and when it did connect i new it wasn’t the SAN. so i went back trying to get the vm to connect i was eventually able to get the vm computer to work.

    – by me accessing this volume with the computer that works(the one that has the C: says NTFS (Bitlocker Encrypted) , is it possible that it encrypted the SAN Volume, and that’s why this computer can access the volume with no problem. It has the key?

    – I didn’t find out that the VM in question’s ISCSI volume saying 1024 GB Unknown (Bitlocker Encrypted) Healthy Active Partition until after i tried all of the mentioned fix attempts below.

    I can’t find anything online that pertains to ISCSI drive and Bitlocker Encrpted so i was hoping someone could help me out.

    This is what i’ve tried so far and failed.

    – Removed portal ip address, refreshed favorites and targets to make sure connection was disconnected. Re-added the portal ip address and connected back.
    – Used disk management to take volume offline and then back online .
    – Logged into the SAN took the volume offline, removed portal ip address, refreshed favorites and targets from the computer. Put SAN volume back online, Re-added the portal ip address and connected back
    – Changed the drive letter
    – restarted VM.


    Kobe 310
    Member
    #363148

    I found the answer through a Bit Locker engineer.

    On the computer with the Bit Locker, (The one that i suspected was the culprit) I was trying to tell him that bit locker wasn’t on, it showed the volumes with TURN ON BIT LOCKER. At first he didn’t believe what I was telling him, he thought i had done something until i sent him screen shots of Bit Locker Manager, Disk Management, and my Veeam server Disk Management. .
    He was dumbfounded, he had only seen 1 case like this years ago.

    He told me to select the drive on the computer that has the bitlocker on it, try to turn it on and encrypt it, when done decrypt it.
    So i did that. It took less than 1 minute to encrypt, but about 6 hours to decrypt. (I ALMOST STOPPED IT BECAUSE I THOUGHT IT HAD BECOME UNRESPONSIVE). When it completed, the drive showed as unencrypted, I then went to my Veeam server, and i was able to get into the drive.

    I asked him what happened and he could not give an answer. He said something wasn’t right. I told him how dangerous that was, if i would have select a diffrent LUN, it would have shut my company down, and i wonder how many other companies this has happen to.

    So I hope that this is being read by Petri users, and this post prevents this from happening to someone else. All i can say is, if you have a computer with bit locker on it, ( FORGOT TO MENTION, THIS WAS BRAND NEW OUT OF THE BOX) DON’T NECESSARILY TRUST IT!!!!!!!!!!!!!!!!

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.