Allow user to install printer driver without administrative right via GPO not working

Home Forums Client Operating Systems Windows 7 Allow user to install printer driver without administrative right via GPO not working

This topic contains 2 replies, has 3 voices, and was last updated by  kwarburton 1 year, 7 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts

  • Roman_k
    Member
    #166935

    Hi
    I have a network with AD 2008 and around 500 win 7 PC. I dont give users admin rights on PCs but want them to be able to install printers shared from server.
    I found a few articles about doing it via GPO and applied all GPs as per book:
    1) Computer ConfigurationPoliciesWindows SettingsSecurity SettingsLocal PoliciesSecurity OptionsDevices: Prevent users from installing printer drivers – Disabled
    2) Computer ConfigurationPoliciesWindows SettingsSecurity SettingsLocal PoliciesSecurity OptionsUser Account Control: Detect application installations and prompt for elevation – Disabled
    3) Computer ConfigurationPoliciesAdministrative TemplatesSystemDriver InstallationAllow non-administrators to install drivers for these device setup classes – Enabled ( {4d36e979-e325-11ce-bfc1-08002be10318} , {4658ee7e-f050-11d1-b6bd-00c04fa372a7} , {48721b56-6795-11d2-b1a8-0080c72e74a2} )

    Group policy is applied to a PC (checked with rsop) but user still getting UAC prompt when trying to connect shared printer.

    Thanks

    #348346

    Hi Roman_k,

    Try the following settings:
    Computer ConfigurationPoliciesAdministrative TemplatesPrinters
    Point and Print Restrictions Enabled
    Users can only point and print to these servers: Disabled
    Enter fully qualified server names separated by semicolons
    Users can only point and print to machines in their forest Disabled

    Security Prompts:
    When installing drivers for a new connection: Do not show warning or elevation prompt
    When updating drivers for an existing connection: Do not show warning or elevation prompt


    kwarburton
    Member
    #386209
    brendon.lieberz;n509986 wrote:
    Hi Roman_k,

    Try the following settings:
    Computer ConfigurationPoliciesAdministrative TemplatesPrinters
    Point and Print Restrictions Enabled
    Users can only point and print to these servers: Disabled
    Enter fully qualified server names separated by semicolons
    Users can only point and print to machines in their forest Disabled

    Security Prompts:
    When installing drivers for a new connection: Do not show warning or elevation prompt
    When updating drivers for an existing connection: Do not show warning or elevation prompt

    Looks like it did the trick
    Thanks a lot

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.