Re: Dreaded OMA Error 1503

Home Forums Messaging Software Exchange 2000 / 2003 Dreaded OMA Error 1503 Re: Dreaded OMA Error 1503


chris2391
Member
#351296

Re: Dreaded OMA Error 1503

Sembee;143398 wrote:
Reset the virtual directories.
http://support.microsoft.com/default.aspx?kbid=883380

Also ensure that you have all post SP2 updates for Exchange 2003 as well.

Simon.

Done. I also deleted the virtual directory created from the KB article, exchange-oma. I assumed I should do that?

I’m still getting the same error. The virtual directories did get recreated, and I did reboot. Here is the description, I’m not sure if it changed or not, still error 1503:

An unknown error occurred while processing the current request:
Message: Object reference not set to an instance of an object.
Source: Microsoft.Exchange.OMA.Preferencing
Stack trace:
at Microsoft.Exchange.OMA.Preferencing.AdUserObject.FindUserViaCreds(NetworkCredential creds, WindowsIdentity identity)
at Microsoft.Exchange.OMA.Preferencing.OmaUserInfo.ClearCache()
at Microsoft.Exchange.OMA.Preferencing.OmaUserInfo..ctor(NetworkCredential creds, WindowsIdentity identity)
at Microsoft.Exchange.OMA.Preferencing.OmaUserInfo..ctor(NetworkCredential creds)
Message: Exception has been thrown by the target of an invocation.
Source: mscorlib
Stack trace:
at System.Reflection.RuntimeConstructorInfo.InternalInvoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean isBinderDefault)
at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
at System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
at System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
at Microsoft.Exchange.OMA.UserInterface.Global.Session_Start(Object sender, EventArgs e)
Message: Exception of type Microsoft.Exchange.OMA.DataProviderInterface.ProviderException was thrown.
EventMessage:
UserMessage: A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator.
Source: Microsoft.Exchange.OMA.UserInterface
Stack trace:
at Microsoft.Exchange.OMA.UserInterface.Global.Session_Start(Object sender, EventArgs e)
at System.Web.SessionState.SessionStateModule.RaiseOnStart(EventArgs e)
at System.Web.SessionState.SessionStateModule.CompleteAcquireState()
at System.Web.SessionState.SessionStateModule.BeginAcquireState(Object source, EventArgs e, AsyncCallback cb, Object extraData)
at System.Web.AsyncEventExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

For more information, see Help and Support Center at