Reply To: How to configure L3 to home router to access internet through cisco router

Home Forums Networking Cisco Routers & Switches How-to How to configure L3 to home router to access internet through cisco router Reply To: How to configure L3 to home router to access internet through cisco router

Avatar
LarryTsikada
Participant
#616268

have an issue that I have been trying to work on for the past few weeks that I can’t seem to get my head around. So I have connected my Cisco 3550 switch to a Wireless Home Router (Netgear R7000). I have setup InterVLAN routing within my 3550 with 3 attached VLANs (VLANs 12, 24, 36) and my R7000 network (VLAN 48). I have assigned my SVI for VLAN 48 an address (172.16.48.3 /24) to communicate with my R7000 home router. Everything in this setup works smoothly from anywhere between 10 minutes to about an hour or so (give or take ping tests) until my 3550 can no longer ping the Gateway IP address setup on the R7000 Home Router (172.16.48.1). The weird part of all of this is that even though I am not able to ping from the console of the 3550 to the 172.16.48.1 address, my Test PC’s connected to the switch (VLAN’s 12 and 24) can still ping it. They end up having full connection to the internet on top of full ping connectivity throughout the network. Now I’ve tried testing this in multiple ways such as changing the Connected Port (fa0/1) on the 3550 to a routed port and assigning it the 172.16.48.3 /24 address manually. This does the same thing that the SVI setup does.. Works for a little while then stops communicating. Now I also have static routes on my R7000 router pointing to the 172.16.12.0/22, 172.16.24.0/22, and 172.16.36.0/28 networks through the 172.16.48.3 address. I also have a default route from my 3550 pointing to the 172.16.48.1 (R7000 gateway IP). I have been trying just about everything including access lists that block DHCP traffic, logging through access lists, debugging ip packets, etc. I have found nothing on this issue. I was wondering if there was any sort of communication that might be sent by the 3550 to the R7000 Home Router that may be setting off a firewall rule on the R7000 (which I can’t seem to find any sort of firewall settings through the GUI of the R7000) or whether the broadcast traffic is being sent and received in different intervals from the R7000. I am almost at a complete loss on this issue and it’s driving me crazy. I just think it’s very weird that the test PC’s can ping and act like nothing is wrong, but at the same time the Fa0/1 interface IP address cannot ping an IP on its own network. I would also like to mention that I have been gradually checking the show arp output to make sure that the 172.16.48.1 address is still allocated to the correct mac address and the age gradually gets higher and higher until I try to ping it from the switch (when it’s working) or ping it from the test PC’s when it’s not working. I have also tried setting it up on a separate port and that has still not worked out.. same issue. The thing is, the port still stays up up and can route packets, but cannot talk from one port (fa0/1) to the R7000. My R7000 is also doing the NAT on the network and am really hoping that isn’t the issue at hand. I have it set to think that the network attached is 172.16.0.0/16 in order to NAT the VLANs connected to the 3550. I also have a Raspberry Pi that is doing the DHCP of the R7000 network with a subnet 172.16.0.0 /16 statement that only assigns addresses in the 172.16.48.0/24 range to that network. That was why I was thinking it was DHCP traffic, thus created an ACL to block this. Still stops pinging after a while. Attached I have my running config of my 3550 and if you have any other questions I am more than willing to give more output as I am losing my mind trying to fix this Lab setup. Thanks in advanced