Announcement

Collapse
No announcement yet.

ESXi 5.5 not saving static IP address under VMWare Workstation

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ESXi 5.5 not saving static IP address under VMWare Workstation

    I currently have 3 ESXi 5.5 vms running inside VMware Workstation v9 for testing purposes.

    esx1 -> 192.168.52.101 (statically assigned inside esxi network settings)
    esx2 -> 192.168.52.102 (statically assigned inside esxi network settings)
    esx3 -> 192.168.52.103 (statically assigned inside esxi network settings)

    All 3 vms have been properly configured with static ip addresses and settings are saved. All 3 vms are using NAT as the network adapter. When I reboot esx1 the vm keeps the static ip address settings but esx2 and esx3 are reverting back to use a dhcp address.

    Why esx2 and esx3 are not saving the static ip address settings?

    Thanks in advanced.

  • #2
    Re: ESXi 5.5 not saving static IP address under VMWare Workstation

    I've never had an issue assigning an IP address to ESXi in Workstation.

    Remember that the settings are as if your building a server on hardware and virtualised.

    Are you restarting the management network after you assign the address?

    https://pubs.vmware.com/vsphere-50/i...6313A6ADB.html

    Comment


    • #3
      Re: ESXi 5.5 not saving static IP address under VMWare Workstation

      I did a "Reset System Configuration" on all 3 esx vms. Configured the 3 vms to use NAT as the network adapter. Start the 3 vms and they properly get a dynamic address: 192.168.52.128, 192.168.52.129 and 192.168.52.130

      If I configure the static ips on the vms and save changes, the vms are not preserving the static ip address configuration. Is reverting back to dhcp.

      Comment


      • #4
        Re: ESXi 5.5 not saving static IP address under VMWare Workstation

        I'm just getting my files organized to see if I can replicate the issue that your having.

        Typically I never use NAT on any VM that I setup but that's personal preference rather than anything else.

        Comment


        • #5
          Re: ESXi 5.5 not saving static IP address under VMWare Workstation

          As part of my troubleshooting, I tested by creating other VMs such as a Windows 8 VM and the Windows 8 VM can use the static IP address without any problems.

          Comment


          • #6
            Re: ESXi 5.5 not saving static IP address under VMWare Workstation

            I've created a VM using all standard settings as per Workstation sets and it worked perfectly fine for me.

            Can you please outline the process you use to set the static address on the VM.

            Comment


            • #7
              Re: ESXi 5.5 not saving static IP address under VMWare Workstation

              I tried this multiple times and no go. I tried exactly what I pasted on my previous posts.
              I will use for now the dynamic IP addresses since each VM is consistently using the same dynamic IPs.

              Thanks for your help.

              Comment

              Working...
              X