No announcement yet.

Cluster in Vmware 4.1

  • Filter
  • Time
  • Show
Clear All
new posts

  • Cluster in Vmware 4.1

    I have some problems with clustering in Vmware, dont know what i am doing wrong. Maybe someone here knows? Here is what i am doing:

    Created 2 new Luns in the San almost the same way that i have done when creating stores for Vm:s. I then rescan devices on all esx servers. Everything went fine and the new lun:s are visible.

    Then the problems start..
    Edit\Add harddisk (raw device mapping
    Specify datastore
    Choose Physical
    Choose a scsi number that are not used
    change the scsi controller to physical

    Server 2
    Add a virtual disk
    Use an existing disk
    Browse to the store where disk is located
    choose same scsi id as on server1
    Check that scsi is physical

    Added the first harddrive to server1 and to server2 (ok)
    Add the second harddrive to server 1 (ok)
    But when i add the second harddrive to server 2 i get a message that there are 2 disks with the same UUID.

    Someone had this issue? It is the same disk so shouldnt it be the same uuid? Servers are not cloned, they are clean installations.


  • #2
    Re: Cluster in Vmware 4.1

    So you're building a MSCS cluster in VMs right?

    I'd recommend reading this document:

    VCP2 / VCP3 / VCP4 / VCP 5 / VCAP-DCA4 / VCI / vExpert 2010-2012


    • #3
      Re: Cluster in Vmware 4.1

      Thanks for the document, but that was exactly how i did this. But i have solved this now. What i did was:
      detach harddrives.
      browse datastore and remove the vmdk:s
      Create stores on another wmfs that i didnt use earlier.
      And now it works? I dont know why, but it works fine now...