Announcement

Collapse
No announcement yet.

Packet loss with VMware Lab Manager 4.01 using Host Spanning

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Packet loss with VMware Lab Manager 4.01 using Host Spanning

    Hopefully there is someone around here witch some knowledge about VMware Lab Manager 4.01.

    So here is the story.
    At the moment we are evaluating VMware vSphere Enterprise plus with VMware Lab manager. We just want to know if this is the products to use for about 150 consultants and engineers.

    At the moment we are able to create machines, create physical networks, Network Templates, Host Spanning Transport Networks etc.

    Anyhow the issue.
    Our internal network looks like 10.1.36.0/23 for our lab using VLAN 36. We also added some other internal networks like 10.1.38.0/24 with vlan 38
    We created some Network Templates for 10.100.1.0/24 & 10.100.2.0/24
    Our physical network is also created for 10.1.36.0/23
    Host Spanning Transport Network is created for VLAN 36

    Anyhow, when we create 2 virtual machines they are nicely distrubuted between the ESX hosts. If we configure them to use the 10.1.36.0/23 network and unfenced we can ping between the 2 VM's.

    However in Fenced mode this is somehow not possible.

    If we assign any other network (.38 or one of the Network Templates) the portgroup on the vDS is created and the machines and hosts are added.

    However we can't ping between the VM's which makes communication impossible.

    So building a DC on ESX01 and an Exchange Server on ESX02 won't work in Lab Manager.

    Any ideas?

    Oh, if this is a bit to cryptic, let me know.... I'm currently do 4 things at a time and I might be a bit unclear..
    Marcel
    Technical Consultant
    Netherlands
    http://www.phetios.com
    http://blog.nessus.nl

    MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
    "No matter how secure, there is always the human factor."

    "Enjoy life today, tomorrow may never come."
    "If you're going through hell, keep going. ~Winston Churchill"


  • #2
    Re: Packet loss with VMware Lab Manager 4.01 using Host Spanning

    Hmmm ok. Update.

    It starts pissing me off.... Today I completly trashed VMware lab manager. Of course after uninstalling it. I really thought, this is a lab manager issue... Well maybe it is.

    However, after reinstalling the machine again including lab manager I created 2 simple XP machines.
    Well Take a look at the first and second image (Thumbs): everything seems fine huh?
    Systems are up, Link is up, Placed in a VLAN36 (subnet 10.1.36.0/23)

    The IP's of the machines are: 10.10.10.1 and 10.10.10.2. It really doesn't matter...

    However, after some monitoring I noticed image 3 (see Attached Images)... Why is eGress traffic blocked??? I found this weird especially since I remembered that the machines where unfenced? So checking in lab manager did confirm I was using unfenced mode, as you can see in Image4 (third thumb).

    Till now I really can't figure it out why or what is happening over here... Anyone?
    Attached Files
    Last edited by Dumber; 10th June 2010, 14:23.
    Marcel
    Technical Consultant
    Netherlands
    http://www.phetios.com
    http://blog.nessus.nl

    MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
    "No matter how secure, there is always the human factor."

    "Enjoy life today, tomorrow may never come."
    "If you're going through hell, keep going. ~Winston Churchill"

    Comment


    • #3
      Re: Packet loss with VMware Lab Manager 4.01 using Host Spanning

      Ok, probably next week I'm going to make some sniffer traces on the physical switches.
      I'm start suspecting this has to do with the Etherchannels...

      This because my co-worker found the same issues while using the VI client.

      Edit:

      Our current switch config

      interface Port-channel22
      description *** ESX12 VMnic1, VMnic2, VMnic3 ***
      switchport trunk encapsulation dot1q
      switchport mode trunk

      interface GigabitEthernet2/0/22
      description *** VMWARE ESX12 ***
      switchport trunk encapsulation dot1q
      switchport mode trunk
      channel-group 22 mode on
      spanning-tree portfast trunk
      !
      interface GigabitEthernet2/0/23
      description *** VMWARE ESX12 ***
      switchport trunk encapsulation dot1q
      switchport mode trunk
      channel-group 22 mode on
      spanning-tree portfast trunk
      !
      interface GigabitEthernet2/0/24
      description *** VMWARE ESX12 ***
      switchport trunk encapsulation dot1q
      switchport mode trunk
      channel-group 22 mode on
      spanning-tree portfast trunk
      Last edited by Dumber; 11th June 2010, 20:27.
      Marcel
      Technical Consultant
      Netherlands
      http://www.phetios.com
      http://blog.nessus.nl

      MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
      "No matter how secure, there is always the human factor."

      "Enjoy life today, tomorrow may never come."
      "If you're going through hell, keep going. ~Winston Churchill"

      Comment


      • #4
        Re: Packet loss with VMware Lab Manager 4.01 using Host Spanning

        OK, removed the etherchannel config on the switches and everything seems fine for now..
        Damn...

        I leave it for a couple weeks to see if this was causing the issue.
        Marcel
        Technical Consultant
        Netherlands
        http://www.phetios.com
        http://blog.nessus.nl

        MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
        "No matter how secure, there is always the human factor."

        "Enjoy life today, tomorrow may never come."
        "If you're going through hell, keep going. ~Winston Churchill"

        Comment


        • #5
          Re: Packet loss with VMware Lab Manager 4.01 using Host Spanning

          Well it's stable, so I leave it like this.
          Marcel
          Technical Consultant
          Netherlands
          http://www.phetios.com
          http://blog.nessus.nl

          MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
          "No matter how secure, there is always the human factor."

          "Enjoy life today, tomorrow may never come."
          "If you're going through hell, keep going. ~Winston Churchill"

          Comment

          Working...
          X