No announcement yet.

Corrupt VMDK

  • Filter
  • Time
  • Show
Clear All
new posts

  • Corrupt VMDK


    I'm having an issue trying to start a guest OS (windows 2000 server) after a server reinstall. I'm using VMware 1.0.8 under Fedora (same version as before the reinstall). After adding the .vmx via the vmware console I click to start and it does nothing. When looking at the vmware.log I see:

    Allot of:

    Jan 21 11:27:23: vmx| DISKLIB-SPARSECHK: [/VirtualMachines/Windows2000/Windows2000-s001.vmdk] 32768 excess bytes at end of file
    Jan 21 11:27:23: vmx| DISKLIB-SPARSECHK: [/VirtualMachines/Windows2000/Windows2000-s001.vmdk] Invalid GD or RGD [0]: 0,2 vs. 259,2

    Then allot of:

    Jan 21 11:16:14: vmx| DISKLIB-SPARSECHK: [/VirtualMachines/Windows2000/Windows2000-s001.vmdk] GT Error (ZG): [3][385] 0/181632

    If I try to defragment the disk via the vmware console I get: Failed to defragment: VMDB Failure

    Additionally if I try to defragment the other disk (there are two), I get: The specific virtual disk needs repair

    I have two backups of this and both give the same errors, I've tried on another host, under vmware player, under vmware 2.0 server. All fail

    I've also tried to mount the vmdk under windows using diskmount, but that also failed.

    Can anyone think of something I might have missed?


  • #2
    Re: Corrupt VMDK

    It seems that the duisk is corrupt and I think that here would be the best place for you to look for help in this matter

    if there is someone that can - then Ulli Hankeln will most probably be the one that can help you.
    Technodrone|@maishsk|Author of VMware vSphere Design
    VMware vExpert 2013-2010,VCAP5-DCA/DCD,VCP
    MSCA 2000/2003, MCSE 2000/2003
    A proud husband and father of 3 girls
    If you find the information useful please don't forget to give reputation points sigpic.

    Have a good one!!