No announcement yet.

ESXi 4.0 installation issues

  • Filter
  • Time
  • Show
Clear All
new posts

  • ESXi 4.0 installation issues

    Hello all -

    Here is the situation I am troubleshooting. I am in the process of building a ESXi 4.0 server that will act as a SAN where 2 separate, ESXi servers will run the necessary VMs and access this SAN station for storage.

    The specifications of this ESXi 4.0 "SAN" computer is as follows:
    Motherboard - Gigabyte GA-MA785G-UD3H
    CPU - AMD Athlon II X2 250 Processor
    RAM - 4GB Corsair XMS2-6400
    PSU - BFG Tech 650W
    HDDs - (2) 320GB Seagate drives & (2) 1TB Western Digital drives
    Storage controller - LSI Logic (LSDISAS1064E)

    Here is what I am attempting to accomplish:

    Originally, I wanted to configure the 2 sets of drives to RAID-1 and then install ESXi 4.0 to the 320GB drive that would then be mirrored. I was able to install ESXi to the 320GB drive, reboot the system after it was completed with installation, and then successfully reboot into the operating system. However, this was before the drives were configured to RAID-1. Every other combination that I tried using the on-board SATA controller, in regards to BIOS settings, I was unsuccessful in booting back into the ESXi 4.0 OS after installation.

    I also tried using the LSI controller, which is compatible with ESXi 3.5 & 4.0 and has been used here at work with other ESXi configurations, and I was unable to successfully install ESXi 4.0. I keep getting an error of, "Failed to add device, too many devices!", "Cannot get bank 1 Warning: Bank 1 partition type invalid. Ignoring.", "Cannot get bank 2 Warning: Bank 2 partition type invalid. Ignoring.".

    At this point, I attempted to install ESXi to a thumb drive which seemingly worked but now I am receiving an error of, "Panic: Cannot get Disk parameters.". I have tried booting into a seemingly successful installation of ESXi off of the USB drive with both the HDDs connected and disconnected, to see if I could pin point the issue; I was unsuccessful with this attempt.

    Lastly, after seeing that there has been some issues with Gigabyte motherboards and booting from a USB drive, I followed the steps in this article - to install the VMware 4.0 ISO directly to the USB to see if it was any different than installing ESXi 4.0 from a CD to a USB. This did not work however.

    Does anyone know what my issue might be or are there any resources that might be helpful in this situation? Thanks for your time.

    Last edited by mike-pds; 7th January 2010, 22:00.

  • #2
    Re: ESXi 4.0 installation issues

    There are issues with USB drive emulation on Gigabyte motherboards. Try using a different imaging tool to create the image. Also, i've heard rumours that the machine you build the image on can have an affect (?!) so try and use Windows XP to create the image (to then copy to the USB drive).