Announcement

Collapse
No announcement yet.

Can't get VM's to see eachother! 2003 DC and XP

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't get VM's to see eachother! 2003 DC and XP

    Got VMServer installed on my home laptop, I have since installed Server 2003 Standard as a VM and have installed XP Professional

    I have installed and configured DHCP and DNS on my server and have added a second NIC, one NIC (named Internal) is set to NAT and my other NIC (external) is set to BRIDGED, I can get on the internet ok on this VM

    The XP VM gets an IP address but not from my server, and when I do an ipconfig /all it doesn't show my DC details

    My default gateway (router) is 192.168.1.254


    IPCONFIG /ALL - From my Server 2003 VM

    Windows IP Configuration
    Host Name . . . . . . . . . . . . : server
    Primary Dns Suffix . . . . . . . : shamone.local
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : shamone.local

    Ethernet adapter Internal:
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : VMware Accelerated AMD PCNet Adapter
    Physical Address. . . . . . . . . : 00-0C-29-94-B8-DB
    DHCP Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 192.168.1.20
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.254
    DNS Servers . . . . . . . . . . . : 4.2.2.2

    Ethernet adapter External:
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : VMware Accelerated AMD PCNet Adapter #2
    Physical Address. . . . . . . . . : 00-0C-29-94-B8-E5
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.1.5
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.254
    DHCP Server . . . . . . . . . . . : 192.168.1.254
    DNS Servers . . . . . . . . . . . : 192.168.1.254
    Lease Obtained. . . . . . . . . . : 01 March 2009 17:13:05
    Lease Expires . . . . . . . . . . : 02 March 2009 17:13:05



    IPCONFIG /ALL - From my XP VM

    Windows IP Configuration
    Host Name . . . . . . . . . . . . : default
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : localdomain

    Ethernet adapter Local Area Connection:
    Connection-specific DNS Suffix . : localdomain
    Description . . . . . . . . . . . : VMware Accelerated AMD PCNet Adapter

    Physical Address. . . . . . . . . : 00-0C-29-58-F5-D1
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.65.128
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.65.2
    DHCP Server . . . . . . . . . . . : 192.168.65.254
    DNS Servers . . . . . . . . . . . : 192.168.65.2
    Primary WINS Server . . . . . . . : 192.168.65.2
    Lease Obtained. . . . . . . . . . : 01 March 2009 17:13:57
    Lease Expires . . . . . . . . . . : 01 March 2009 17:43:57


    Any ideas how I can get my XP VM to see the Server 2003 VM? Firewalls are disbled on on both VM's. I don't think its a problem with the VM's, I think its a problem with my virtual network settings, (NAT, Bridged etc)

    Thanks

  • #2
    Re: Can't get VM's to see eachother! 2003 DC and XP

    I have just remembered to disable the VMWARE DHCP service on my laptop, since stopping and disabling this service my XP VM gets limited or no connectivity, see below for the latest ipconfig on my XP VM...

    Windows IP Configuration
    Host Name . . . . . . . . . . . . : default
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : VMware Accelerated AMD PCNet Adapte

    Physical Address. . . . . . . . . : 00-0C-29-58-F5-D1
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Autoconfiguration IP Address. . . : 169.254.18.56
    Subnet Mask . . . . . . . . . . . : 255.255.0.0
    Default Gateway . . . . . . . . . :
    Last edited by noob0259; 1st March 2009, 19:54.

    Comment


    • #3
      Re: Can't get VM's to see eachother! 2003 DC and XP

      Your laptop needs to get an ip from the 2003 machine, and have that as its dns server.
      Easiest way would be to turn off the DHCP service on your router and use the one on the 2003 VM, on the DHCP console, youd have to enter your routers IP as the gateway for the DHCP service to give out

      Comment


      • #4
        Re: Can't get VM's to see eachother! 2003 DC and XP

        XP that is on my laptop is only there for VM Server to sit on, within VM Server I have 2 VM's, XP and Server 2003, I don't want XP (that is installed on the laptop itself) to have anything to do with these VM's...

        Comment


        • #5
          Re: Can't get VM's to see eachother! 2003 DC and XP

          If you want the XP VM to receive an IP from the Windows 2003 you will have to put it on a host only network. If you want then the XP to out to the Internet you will have to enable RRAS on the 2003 Server for it to act as your router

          Maish
          ----------------------------------------------------------
          Technodrone|@maishsk|Author of VMware vSphere Design
          VMware vExpert 2013-2010,VCAP5-DCA/DCD,VCP
          MSCA 2000/2003, MCSE 2000/2003
          A proud husband and father of 3 girls
          ----------------------------------------------------------
          If you find the information useful please don't forget to give reputation points sigpic.

          Have a good one!!

          Comment

          Working...
          X