Announcement

Collapse
No announcement yet.

Cannot see iSCSI

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot see iSCSI

    Hi,

    I have a new ESX 3.5 Installation and have installed OpenFiler on my HP NAS Box. I have configured everything according the the documents on this website, but when I add the IP address of the OpenFiler box to the iSCSI settings in ESX and do a rescan - no iSCSI target shows up.

    Any help would be appreciated.

  • #2
    Re: Cannot see iSCSI

    Originally posted by thorpen View Post
    Hi,

    I have a new ESX 3.5 Installation and have installed OpenFiler on my HP NAS Box. I have configured everything according the the documents on this website, but when I add the IP address of the OpenFiler box to the iSCSI settings in ESX and do a rescan - no iSCSI target shows up.

    Any help would be appreciated.
    Be sure you've opened the necessary firewall ports on your ESX host.

    Via the COS, the necessary service can be enabled by issuing the following command:

    esxcfg-firewall -e swISCSIClient

    Another classic reason you can't see iSCSI storage on the Openfiler box is that you don't have a network defined for your ESX host(s) or you have not "ALLOWED" iSCSI access to that defined network which is one of the steps in setting up the Openfiler storage.

    Another possibility is the iSCSI service is disabled on the Openfiler box or perhaps you have CHAP authentication issues. If you have CHAP enabled, disable that for the time being so that you can troubleshoot the basics.
    Last edited by jasonboche; 13th June 2008, 14:00.
    VCDX3 #34, VCDX4, VCDX5, VCAP4-DCA #14, VCAP4-DCD #35, VCAP5-DCD, VCPx4, vEXPERTx4, MCSEx3, MCSAx2, MCP, CCAx2, A+
    boche.net - VMware Virtualization Evangelist
    My advice has no warranties. Follow at your own risk.

    Comment


    • #3
      Re: Cannot see iSCSI

      Thanks for getting back to me.

      I have checked the firewall and run the command you specified just to confirm.

      The network is created in OpenFiler and enabled.

      The iSCSI service is enabled and CHAP is disabled.

      I have re-scanned the storage adaptors, but still do not have any targets appearing.

      Comment


      • #4
        Re: Cannot see iSCSI

        Hello.

        How about dropping to the COS and using the command /usr/sbin/esxcfg-rescan
        VCDX3 #34, VCDX4, VCDX5, VCAP4-DCA #14, VCAP4-DCD #35, VCAP5-DCD, VCPx4, vEXPERTx4, MCSEx3, MCSAx2, MCP, CCAx2, A+
        boche.net - VMware Virtualization Evangelist
        My advice has no warranties. Follow at your own risk.

        Comment


        • #5
          Re: Cannot see iSCSI

          I tried the following:

          /usr/bin/esx-cfg-rescan vmhba32

          and got

          on scsi1, removing :.
          on scsi1, adding:.

          Comment


          • #6
            Re: Cannot see iSCSI

            I would also like to offer you my openfiler build document which is more comprehensive/detailed than the nice procedure David Davis wrote up. It may give you some insight or places to check to see if something was missed on the Openfiler side. I'm leaning towards the problem being on the Openfiler side rather than the ESX side, but you do need to make sure all the things are configured properly on the ESX side.

            One more thing to check, Are you sure you have created VMKernel portgroup on your ESX host with the properly IP address and gateway, and that portgroup is tied to physical NIC which has physical cabling to a switch which is physically connected to the Openfiler server?

            On the Openfiler server, you might try pinging the VMKernel IP iSCSI portgroup address to see if you get a reply.
            VCDX3 #34, VCDX4, VCDX5, VCAP4-DCA #14, VCAP4-DCD #35, VCAP5-DCD, VCPx4, vEXPERTx4, MCSEx3, MCSAx2, MCP, CCAx2, A+
            boche.net - VMware Virtualization Evangelist
            My advice has no warranties. Follow at your own risk.

            Comment


            • #7
              Re: Cannot see iSCSI

              Originally posted by thorpen View Post
              I tried the following:

              /usr/bin/esx-cfg-rescan vmhba32

              and got

              on scsi1, removing :.
              on scsi1, adding:.
              Ok thanks. That verifies that the CLI rescan isn't seeing anything either. Let me go grab my Openfiler build document for you.
              VCDX3 #34, VCDX4, VCDX5, VCAP4-DCA #14, VCAP4-DCD #35, VCAP5-DCD, VCPx4, vEXPERTx4, MCSEx3, MCSAx2, MCP, CCAx2, A+
              boche.net - VMware Virtualization Evangelist
              My advice has no warranties. Follow at your own risk.

              Comment


              • #8
                Re: Cannot see iSCSI

                Here's a link to my Openfiler build document. When viewing some of the configuration settings, keep in mind it's specific to my Openfiler hardware. Adapt it to what you have:

                http://www.boche.net/dropbox/Openfil...t%20build.docx
                VCDX3 #34, VCDX4, VCDX5, VCAP4-DCA #14, VCAP4-DCD #35, VCAP5-DCD, VCPx4, vEXPERTx4, MCSEx3, MCSAx2, MCP, CCAx2, A+
                boche.net - VMware Virtualization Evangelist
                My advice has no warranties. Follow at your own risk.

                Comment

                Working...
                X