No announcement yet.

Squid/Web Filtering Appliance

  • Filter
  • Time
  • Show
Clear All
new posts

  • Squid/Web Filtering Appliance

    Greets all,
    somewhat new to the virtualization world and what I have been playing with thus far is phenomenal. I have a question about Squid Webfiltering appliance which maybe really easy for you veterans.
    I was on vmware site to download the virtual appliance to run Squid web filtering with Dansgaurdian on my vmware server 1.04 on a win xp machine with a quadcoe and 2gb ram. I downloaded the vm appliance and powered on changed the ip via netconfig like it says to do in the instructions. (took me longer to d/l then it did to get it running etc. I set this up. I had my browser pointing to that proxy and it blocked pages for the appropriate ones that I have tested 9adult stufff) Now here is the head scarther part.
    the instructions say to access the web reports typ in https://yourips/squid-reports
    I did that and basically get an error of page cannot be found I downloaded the webmin version of it. I did also post this on the foum on vm ware but I am not gettign any answers besides a gentlemen tellingme "hey mine works" which really didnt tell me anything. So have any of you folks played withthis specific appliance and if so succssfull with the reporting??
    Here is the site hosting the appliance (yes, I asked them to and I just get reports that there email server is down)

    I get the following:
    The requested URL could not be retrieved
    While trying to retrieve the URL:
    The following error was encountered:
    Connection to Failed
    The system returned:
    +(111) Connection refused+
    The remote host or network may be down. Please try the request again.
    Your cache administrator is webmaster.
    <address>Generated Tue, 25 Dec 2007 17:41:40 GMT by squid.localhost.localdomain (squid/2.6.STABLE6) </address>

    Please advise

  • #2
    Re: Squid/Web Filtering Appliance

    firewall blocking port 443 maybe?

    on a simple linux box, there are lots of ways to see if a process is running, starting with the actual process review, to running nmap localhost
    Honda VFR400
    Last edited by DYasny; 6th March 2011, 17:56.
    Real stupidity always beats Artificial Intelligence (c) Terry Pratchett

    BA (BM), RHCE, MCSE, DCSE, Linux+, Network+


    • #3
      Re: Squid/Web Filtering Appliance

      443 is open


      • #4
        Re: Squid/Web Filtering Appliance

        im not a squid expert by anymeans, but i wanted to try to help you with a little google and some free time, so here it goes...

        have you already tried the squid FAQ? im sure you have, cause thats the obvious starting point, but the section entitled "How do I configure Squid to work behind a firewall?" may be applicable to your situation.

        take a look over it if you havent done so, and see if offers any help. if not, then supply us with a little bit of topology information and get back to us. im confused where the thing is and what you mean 'hosted'? you were saying that it was a vmware machine... does this company host virtual machines? if so, that cool, cause i didnt know people did that... but point being that your proxy is located outside the network? that doesnt sound right, thus some topology info would really help... whats at the dmark, whats after the dmark, and whats between the dmark and the squidbox? how is it connected?
        Last edited by James Haynes; 29th December 2007, 05:59.
        its easier to beg forgiveness than ask permission.
        Give karma where karma is due...


        • #5
          Re: Squid/Web Filtering Appliance

          Hi James,
          Thanks for your reply and yes I have been googling perhaps not enough.. However the appliance was simply (almost) a plug and play option. Not sure if anyone reading this has used the same appliance or not . If so i wish they would chime in.

          Here is a snippet from thier site:
          APF Firewall: with the following incoming ports opened
          TCP 22
          TCP 443
          TCP 3128
          TCP 8080

          Here is the link where I got it from:

          My topology is quite simple "i think"

          Cable Modem at home with PiX501 firewall to keep my internal safe from the bad guys.
          My internal ip address scheme is 10.0.0.x/24

          I have vmware server setup on my pc (my pc has a ip assigned to it dynamically )from the Pix dhcp.
          I installed the appliance. followed the instructions on how to go into the appliance and set the proxy a static IP which I gave it one as

          I adjust my browser (i.e. 7) proxy with the ip of I would test it by going to site that I think it would block (such as adult,porn sites) which it did block with success! However I wanted to go into the web reporting of it:
          (snippet from site
          Sarg Reporting:

          Squid reporting can now be viewed from the following link:
          So I went to

          When i tried that i got the error I posted in my initial post.

          I do not believe i need to do anything with my pix firewall cause I can get internet sites with no problems and it blocks as specified but as mentioned when i try to go to the (internal) I get error.

          I suppose I will google on this more.. but I hope that was a tiny bit clearer on topology

          again thanks for taking the time to reply..
          Last edited by PLANZ; 29th December 2007, 17:08.