Announcement

Collapse
No announcement yet.

help with apache under virtual pc & xpmode

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • help with apache under virtual pc & xpmode

    I run a Website, WebBBS and Dos BBS (via Telnet) under Apache 2.0.52 Wb Server. Since upgarding to a Windows 7 pro machine some of the Dos apps won't work because of the 64 bit processor so I installed Virtual PC & Xp Mode
    software.
    I got everything installed in the vm and it looks ok, except that Apache, though it seemed to install correctly with no errors, isn't working. It works fine via Localhost mode, it's not accessable via http. I tried going into Windows 7 and stopped Apache with no luck. Next I uninstalled it from Windows 7 and did a
    Restart of Apache on the vm, but it still didn't work, other than Localhost mode.
    Is there a setting in XP Mode Control Panel I need to address?

    Thanks in advance...

  • #2
    Re: help with apache under virtual pc & xpmode

    i'm unclear - is Apache installed on the windows7 host, or the xpm ?

    I ask because you state that you installed everything on the xpm host, but then you talk about viewing apache services on the win7 host ....

    if you could also clarify "fine using localhost mode" ?
    do you mean, that with apache installed on thre XPM system, you can browse it when logged onto that system, but you cannot browse it from the win7 machine ?
    Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

    Comment


    • #3
      Re: help with apache under virtual pc & xpmode

      [QUOTE=tehcamel;199488]i'm unclear - is Apache installed on the windows7 host, or the xpm ?

      I ask because you state that you installed everything on the xpm host, but then you talk about viewing apache services on the win7 host ....

      Apache is installed on the native Windows 7 machine and everything works correctly, Web Server + Web BBS + Dos BBS (via Telnet).
      Some (most) of the apps on the Dos BBS won't work in 64 bit so I installed Windows Virtual PC + Xp Mode software thn installed Apache on the VM.

      if you could also clarify "fine using localhost mode" ?

      It would probably help if we set aside Windows 7 for now. My problems are all in Virtual PC and Xp Mode where I have Apache installed. There's also a copy of Internet Explore, that works. Loading Internet Explorer (on the VM) if I type Localhost on the browser bar it brings up the website (so Apache is installed correctly). If I enter http://country-computer.net it doesn't come up.
      I tried stopping Apache on the Windows 7 side. No luck. I then uninstalled Apache on the Windows 7 side. No luck. Apache still doesn't come up on the VM other than Localhost mode.

      Thanks again...

      Comment


      • #4
        Re: help with apache under virtual pc & xpmode

        How is networking on the XPMode machine set up -- can it get on the internet?
        If so:
        Have you given it a static IP (internally) and forwarded port 80 from your router to it
        Can you (from Win7) access Apache by (internal) IP?
        Can you access it by host name?
        I presume your public IP and DNS are all OK?
        Tom Jones
        MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
        PhD, MSc, FIAP, MIITT
        IT Trainer / Consultant
        Ossian Ltd
        Scotland

        ** Remember to give credit where credit is due and leave reputation points where appropriate **

        Comment


        • #5
          Re: help with apache under virtual pc & xpmode

          Originally posted by Ossian View Post
          How is networking on the XPMode machine set up -- can it get on the internet?
          The browser works fine. No problem there.
          If so Have you given it a static IP (internally) and forwarded port 80 from your router to it

          No router connected yet. It's a stand alone PC system.

          Can you (from Win7) access Apache by (internal) IP?
          Can you access it by host name?
          I presume your public IP and DNS are all OK?
          Under Window 7 Pro everything works fine. Apache, Web BBS and Dos BBS via telnet.
          I've gone away from Windows 7 Virtual PC and XP Mode and am trying out VNWare Lite Workstation. It has, basically, the same problem with the Website not being accessable in other than Localhost mode. Sometimes the most obvious answer is staring you in the face,. I hope that's the case here. Just being new to virtualization or perhaps a setting I may have overlooked. But for the life of me I can't think of a thing I may have overlooked.

          Later...

          Comment


          • #6
            Re: help with apache under virtual pc & xpmode

            Originally posted by Dr Tom
            Have you given it a static IP (internally) and forwarded port 80 from your router to it
            Would be nice to see what settings you have used but now that you have moved to VMWare Lite I will be as much in the dark as you. Fortunately other far more clever than me can help with that.
            1 1 was a racehorse.
            2 2 was 1 2.
            1 1 1 1 race 1 day,
            2 2 1 1 2

            Comment

            Working...
            X