No announcement yet.

Integration services determined not to install

  • Filter
  • Time
  • Show
Clear All
new posts

  • Integration services determined not to install

    Yarrr mateys! I need your assistance

    I recently migrated a physical server to virtual using disk2vhd SysInternals tool.
    Server boots up just fine, but when I insert Guest Integration Services disk (or something like that, I can never remember the name as everyone calls it differently)
    things become strange.

    I see messages like:
    - Updating HAL
    - Installing Framework
    - Updating Storport driver

    And then - "please restart".

    OK, like every good sailor I restart the machine.
    But when it starts up, Integration Services do not continue the installation.
    No 5 new services are installed, and no registry keys (out of my memory - HKLM\software\microsoft\hyper-v , and then 3 subdirectories) are created.

    I looked *everywhere* and consulted a bunch of documentation, troubleshooting FAQs, forums and whatnot. I just can't sort this out.

    Device Manager says nothing, no warnings or yellow exclamation marks.
    Also, I checked if I am a member of administrators group, and it's positive.
    Service Pack 2 is also installed, and I ran out of places to check.
    (I even checked for msconfig / boot / advanced / hal , even though it's not present... but I had nothing left)

    Oh, and the server runs Windows Server 2003 Standard Edition.

    Can anyone provide any starting point, tip, advice.. anything?

    Even if you have no solution to offer, thank you very much for taking the time to read.

  • #2
    Re: Integration services determined not to install

    Looks like I'll be alone on this one... :/


    • #3
      Re: Integration services determined not to install

      Any logs created??

      Any entries in Event Viewer???


      • #4
        Re: Integration services determined not to install

        Hello wullieb1,

        Thank you very much for your interest in this matter.

        I realize I failed to provide any log information, but now that I checked (after trying to install IS again and rebooting), there is nothing regarding Integration Services in Event log.

        Just some expected errors about machine not being able to set up a session with domain controller, SQL server connection reports and generally stuff that are tied to network connection. NICs are not recognized, so internet access is not possible.

        There is one thing odd, tho. "Windows Server 2003 Hotfix KB943295 was installed". I assume IS setup did.

        An update enables support for Storport virtual miniports in Windows Server 2003
        (can't make a link, i have less than 5 posts)

        That was System log. Application log says "Product: Hyper-V Integration Services (version 6.1.7600.16385) -- Configuration completed successfully".
        Machine then goes into reboot, and nothing happens :S

        Is there a log file specific to IS installation? That might reveal more, but I was unable to find it.


        • #5
          Re: Integration services determined not to install

          I don't have any experience with Hyper-V b ut is there anything setup where the install is removed on boot???

          I would try a new install, clean if possible, and try it on that server. If successful then we know that the issue is with that machine, else it could be a server config.


          • #6
            Re: Integration services determined not to install

            Originally posted by omgpirate View Post
            Windows Server 2003 Standard Edition.
            Is the hardware you migrated from a SMP system? Have you tired to change the HAL? The thing is, Server 2003 installs either uniprocessor HAL or SMP HAL and switching those is not automatic. Vista/Server2008 do install only SMP HAL, so no switching is needed.

            Sometimes P2V doesn't quite work like it is supposed to. On the other day, I online virtualized a 4-way 2003 server into Hyper-V with System Center Virtual Machine Manager. (The system was online, not on WinPE boot which is offline mode.) All was fine and dandy until I tried to boot the fresh VM. It was dog slow. Way beyond anything usable. Logon took like 10 minutes and still no desktop. CAD prompt appeared after waiting for a minute or the like. The fix was to add another a virtual CPU for the guest. After trying and booting the system with 2 CPUs, it worked just fine. After installing the integration services, I was able to remove the other CPU and it still worked as it should.