No announcement yet.

NO IP Address on Hyper-V 2003 Server guest OS

  • Filter
  • Time
  • Show
Clear All
new posts

  • NO IP Address on Hyper-V 2003 Server guest OS

    I'm restoring an old 2003 SQL Server into Hyper V from it's VHD. Which has succeeded except that it shows the Network is disconnected with the little 2 computers in the bottom right corner, and the red X. If I go to the network cards config and look at the IPv4 settings i can set the static IP, or place it on DHCP assigned, either way there is no network connection. If I run an IP config I get "Windows IP Configuration" and nothing more (See Screen shot) I have run:

    ipconfig /flushdns

    ipconfig /registerdns

    ipconfig /release

    ipconfig /renew

    NETSH winsock reset catalog

    NETSH int ipv4 reset reset.log

    NETSH int ipv6 reset reset.log

    Rebooteded and still nothing.

    I am not able to delete the NIC because the OS says it's required for boot. I have tried to delete it in safemode with networking as well. Basic Safe mode does not show the network adapter.

    I am able to ping, but not the statically assigned IP, and DHCP does not pull an IP.

    Thoughts? Please Help!

  • #2
    Have you installed the Hyper-V additions? If not, I doubt if you will have a valid NiC Driver

    Moved to HyperV forum as SBS is not the best place for this question.
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    IT Trainer / Consultant
    Ossian Ltd

    ** Remember to give credit where credit is due and leave reputation points where appropriate **


    • #3
      At this time, trying to install the integration tools seems like a lost cause, it's in an install\reboot loop. I've tried changing the processor type from ACPI Multiprocessor PC to Standard Computer. I just rebooted into the non Disk2VHD startup, and it appears to be installing, We'll see how things go after this. I will post if this fixes anything\everything as I want to make sure the next person can find what actually worked. Stand by


      • #4
        What type of virtual network adapter does this VM have? I might suggest using the Legacy network adapter.


        • #5
          Okay, so I found an obscure article on Google Groups that said to use the start up instance NOT labeled Disk2VHD. It started up quickly and allowed me to install the integration tools. Rebooted back into the same Start up and NOW I am able to setup the NIC Cards and access the Network\internet. Thanks for the help everyone:

          FINAL SOLUTION: Boot into the NON Disk2VHD startup configuration, then install the integration tools, reboot and again load into the NON Disk2VHD startup.

          Hope that helps others in the future!