Announcement

Collapse
No announcement yet.

incorrect time on Hyper-V Linux guests after sleeping

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • incorrect time on Hyper-V Linux guests after sleeping

    Hi guys,

    I have been troubleshooting this problem for about a month now. I am running Linux guests on Windows 10 Hyper-V hosts.

    Creating mainly Debian Linux guest VMs, when I am all done and allow the Windows host to sleep - the VM will automatically save just fine. When the Windows machine wakes, the Linux VM also does. However, the time in the VM will be whatever time it was when it slept.

    All I need to do to correct this is save it and restart it, then time is correct. Or, within the guest, change any time sync setting, and it snaps back to the correct time immediately. Rebooting the guest or host obviously works too. It is only the sleep/wake situation where the guest loses sync. I have looked at event logs on the host, nothing interesting there. This all completely new hardware, completely clean installs - the problem is easily reproducible, even after re-installing both host and guest.

    I actually have another Windows 10 host that does NOT have this problem - and it is older hardware. I also tried another fresh install on another late model Windows 10 machine here, same problem. I explored all the Hyper-V guest extension support modules and so on - and verified multiple times that they are installed and running correctly in the guests. The correct and necessary modules are baked in to Debian 8.6. Even so, since MS appears to favor CentOS a bit more support-wise, I tried a CentOS guest - same issue exactly.

    This is an annoying problem, but it is not intermittent and seems like it should be easily fixed - what am I missing? Thanks.
Working...
X