Announcement

Collapse
No announcement yet.

ISCSI initiator not reconnecting on reboot

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ISCSI initiator not reconnecting on reboot

    Hi Guys

    I am having an issue at the moment.

    I have 3 HP DL380 G5 hosts for my VM's, running Server 2008 DataCenter edition. They are connecting to a HP MSA2012I SAN via ISCSI.

    I am using failover clustering.
    Disks are all Basic not Dynamic

    This is my issue

    When the hosts are rebooted none of the reserved clustered drives or additional mapped drives to the SAN are visable. The initiator is showing connected but is not. I have to log off the initiator then connect again, the tick is always missing too from the "always reconnect checkbox"

    Any ideas, thanks in advance
    Last edited by mwilliams; 30th January 2009, 23:19.

  • #2
    Re: ISCSI initiator not reconnecting on reboot

    Do you see any errors in the event log? Something?
    Cheers,

    Daniel Petri
    Microsoft Most Valuable Professional - Active Directory Directory Services
    MCSA/E, MCTS, MCITP, MCT

    Comment


    • #3
      Re: ISCSI initiator not reconnecting on reboot

      Further questions:
      Does this happen on all three servers?
      Are these servers new, or older and it was OK until some time ago?
      What version of PSP do you have on the servers?
      Were the servers installed with SmartStart?
      I would try to define additional volumes on the MSA and map them to the servers, and see if the behavior remains.

      Sorin Solomon


      In order to succeed, your desire for success should be greater than your fear of failure.
      -

      Comment


      • #4
        Re: ISCSI initiator not reconnecting on reboot

        I carried out more testing yesterday and discovered the following.

        If i remove the VM from the fail over cluster the mapped volumes come online after reboot.

        As the fail over clustering is not essential at the moment i may wait for Hyper-V R2 to be released from Beta

        Comment


        • #5
          Re: ISCSI initiator not reconnecting on reboot

          Odd....
          Thank you for posting back the outcome...

          Sorin Solomon


          In order to succeed, your desire for success should be greater than your fear of failure.
          -

          Comment

          Working...
          X