Announcement

Collapse
No announcement yet.

Deployed Printers Intermittent

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Deployed Printers Intermittent

    I have a print server running 2016, and a production TS that is used by employees that is a 2008R2. I have GPO's for certain printers, for certain users. When a user logs on, sometimes the deployed printer shows up, and sometimes it doesn't, more often not. Sometimes printers show up that they should not see.

    Maybe i'm not setting this up correctly, there are so many different articles on how to set them up, tough to understand.


    Any Idea's Thanks.

  • #2
    Start by running a RSoP to check the policy is applied.
    Since it is on a TS (and presumably not on their desktops) where is the policy applied (computer or user section) and if it is computer, is loopback processing enabled?

    How did you create the policy - GP Preferences or using the print console?
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3


      Thanks for responding Ossian!!!


      Originally posted by Ossian View Post
      Start by running a RSoP to check the policy is applied.
      i read up on how to use the rsop, ran it, not sure how to say this, but i dont see any wording for printer in the Resultant Set Of Policy.

      Originally posted by Ossian View Post
      Since it is on a TS (and presumably not on their desktops) where is the policy applied (computer or user section)
      I applied in the user section of the DC , i have 3 TS's that get their policies from there in a Group Policy called Desktop Lockdown which is within an OU called .Desktop Users, which works like a charm. So within this Group Policy I created the Print Group policy's in an OU called Printers. So i have several GPO's in this OU, i then went to my printer server, and within the print management console, i selected the printer under the local print server, then selected Deploy with group policy, browsed to the policy, and selected add, and ok. Once the popup verified successful, i looked in the deployed section below, and it would be listed.I then would go to the DC, select the policy, select edit, i would go to User Configuration/Window Settings/Deployed Printers to see if the printer showed up there, which it did.


      So since this issue is interment, i created a GPO under the Domain Name, with the same printers, but giving diffrent users access, hoping that one of these GPO's would work that way i could find out which one was applying. I'm sure i'm probubly doing this the hard way, but it's the best way i know how to trouble shoot. It's just really hard to troubleshoot when it works every other 3 times, and then the users i give access to get a printer that i didn't give them access too. ARRGGHHH!!!!

      Originally posted by Ossian View Post
      is loopback processing enabled?

      I looked up what loopback processing was, went to users/administrative templates/group policy/(and saw Use Group Policy Loopback Processing Mode)...not sure if that's it. But it's only on the Compute section, not the user. (Should this be done on the print server?
      Last edited by Kobe 310; 20th December 2017, 21:47.

      Comment


      • #4
        Start by checking for the application of the Printers policy (that is the name you use, but check for the actual policy name).

        Loopback should not be needed in this case.

        Are your users in the Printers OU?
        Tom Jones
        MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
        PhD, MSc, FIAP, MIITT
        IT Trainer / Consultant
        Ossian Ltd
        Scotland

        ** Remember to give credit where credit is due and leave reputation points where appropriate **

        Comment


        • #5
          Originally posted by Ossian View Post
          Start by checking for the application of the Printers policy (that is the name you use, but check for the actual policy name).

          When i create a group policy"and apply it here", the only thing i do to that policy, is double click it, go to Delegation, and select the users that it will apply to.


          Originally posted by Ossian View Post
          Are your users in the Printers OU?
          Above is how the users would be in the Printers OU, if that's the right way to do it.


          Here is what my DC looks like, you'll see i have GP's for printers under the main domian, and also under the main or Parent OU(If that 's the right wordage to use) in "Company Users". The GP "Desktop Lockdown" is used for my terminal servers, its my main GP sos i just assumed the OU Company Users would be the proper place to create the Printers OU.

          As i mentioned before, the reason i have printers on 2 locations was to troubleshoot, to see which one would apply
          Attached Files
          Last edited by Kobe 310; 22nd December 2017, 15:53.

          Comment

          Working...
          X