Announcement

Collapse
No announcement yet.

Slow network performance

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Slow network performance

    Hi everyone
    I have a small windows network setup, one Server 2012 Essentials server (File Sharing, DHCP, DNS) and 5 Windows 7 Professional PC's all connected to one domain on a 1gbps network.
    One PC is very slow (upto 4mbps) when accessing the file share on the server, but if it is accessing the files of another pc in the domain, it is normal speed. All the other PC's are working fine with the server file share.
    Any ideas anyone?

  • #2
    Re: Slow network performance

    Hi, just a couple of things you can try, updating the network card drivers, replacing the cable. Checking for errors on the switch on the port it connects to. Performing a cable test from the port to the other end where it connects to the switch.
    Please remember to award reputation points if you have received good advice.
    I do tend to think 'outside the box' so others may not always share the same views.

    MCITP -W7,
    MCSA+Messaging, CCENT, ICND2 slowly getting around to.

    Comment


    • #3
      Re: Slow network performance

      It isn't a problem with that specific pc because it communicates with the other client pc's at gigabit speeds, its only a problem when communicating with the server (and the server communicates fine at gigabit with the other pc's. Thanks

      Comment


      • #4
        Re: Slow network performance

        Any antivirus software in play? Maybe worth ruling it out.
        Please remember to award reputation points if you have received good advice.
        I do tend to think 'outside the box' so others may not always share the same views.

        MCITP -W7,
        MCSA+Messaging, CCENT, ICND2 slowly getting around to.

        Comment


        • #5
          Re: Slow network performance

          No antivirus on the client

          Comment


          • #6
            Re: Slow network performance

            What troubleshooting have you done so far?
            Please remember to award reputation points if you have received good advice.
            I do tend to think 'outside the box' so others may not always share the same views.

            MCITP -W7,
            MCSA+Messaging, CCENT, ICND2 slowly getting around to.

            Comment


            • #7
              Re: Slow network performance

              I haven't done much. Not sure where to start as it doesn't seem to be a hardware fault. Any ideas?

              Comment


              • #8
                Re: Slow network performance

                How are you opening these files through office, through explorer, what version of office?
                Which types of files are you trying to open, xls, doc, blueray dvd's, which filesizes.
                Does the nic card show an orange light instead of a green one?

                If it's office, maybe you could try the same thing running office in safemode, with out addons, maybe make sure it is fully patched, and has it's service packs.
                If it's the OS then check that is fully patched/updated too.
                Servers event logs are a good place to look too, may help to point in the right direction
                Plus checking resource monitor on the server at the time of file access.
                There are performance monitor traces you can run.
                http://technet.microsoft.com/en-us/m....08.pulse.aspx
                Running wireshark on the pc and checking whats happening when your trying to open the file may also help point in the right direction.
                Last edited by uk_network; 3rd June 2014, 14:53.
                Please remember to award reputation points if you have received good advice.
                I do tend to think 'outside the box' so others may not always share the same views.

                MCITP -W7,
                MCSA+Messaging, CCENT, ICND2 slowly getting around to.

                Comment


                • #9
                  Re: Slow network performance

                  Hi I ran wireshark and noticed it was running at SMB1 so I enabled SMB2/3 and now it is running at 60Mbps which is a major improvement.
                  Thank you uk_network for your help.

                  Comment


                  • #10
                    Re: Slow network performance

                    Glad you got it sorted.
                    Please remember to award reputation points if you have received good advice.
                    I do tend to think 'outside the box' so others may not always share the same views.

                    MCITP -W7,
                    MCSA+Messaging, CCENT, ICND2 slowly getting around to.

                    Comment

                    Working...
                    X