No announcement yet.

Mapped Drives show a red cross in Terminal Server 2012

  • Filter
  • Time
  • Show
Clear All
new posts

  • Mapped Drives show a red cross in Terminal Server 2012

    Have recently built a new Windows 2012 R2 sever on the network and installed Remote Desktop Services. When users connect to the 2012 Terminal Server, their mapped drives show a red cross. They are still able to access the network drive though and when they do, the red cross does not disappear.
    Have spent countless hours researching this problem on the internet but still haven't found a fix. Have tried the following
    - Instead of mapping drives using GPO, have used a logon .VBS script
    Deleted TS user profile
    ran command net config server /autodisconnect:-1
    - HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic e\lanmanworkstation\parameters Value: KeepConn
    Data type : REG_DWORD
    Value : 65535
    enabled the GPO Always wait for the network at computer startup and logon
    Read the following articles. Couldn't do much as these articles don't apply to Windows 2012
    (Sorry, cant post links to the KB articles as forum does not allow me, coz am a new member)
    KB 938062
    KB 2551503/
    KB 2775511

    - The first user that connects to the Terminal Server session gets the drives mapped fine however subsequent users get the red cross in their drive mappings
    Am at my wits end! Have even tried rebuilding the server from scratch but the problem still exists. I don't have any problems on another server Windows 2008 TS with the same GPO being applied to the users.
    - These DFS shares are located on the network on a Windows 2008 R2 server.
    We were always using vbscript to maps drives on 150 desktops & 1 2008 TS and never had problems.
    Then when we decided to build Windows 2012 RDS, we moved away to GPO. However when the red cross on the mapped drives started appearing, thought there were problems with the GPO on Windows 2012 RDS
    Currently our desktops and 1 TS are using GPO to map drives and are not having any problems. The same GPO when applied to Windows 2012, the red cross appears. If I remove the GPO on Windows 2012 and use VBScript instead the same issue occurs.
    We have 1 NTFS share on an application server & 11 DFS mapped drives to a file server . Of which 9 DFS mapped drives show as disconnected ( file server ), No problems with the other NTFS share as it does not show as disconnected.

    Has anyone come across this problem ???

  • #2
    Re: Mapped Drives show a red cross in Terminal Server 2012

    This was very common with mapped drives on XP and it involved a registry setting. Rems enlightened me to that as there was a 5 minutes from not using the drive until the red X appeared. The Reg Key was changed to 512 years so subsequently that X never appeared again. I am wondering if you may have found a bug. If clicking on it still allows access then I really don't see the point of a rebuild to fix a cosmetic issue. How would you justify that. Maybe just advise your users that this is going to happen and Microsoft are working on a fix. If you have a TechNet subscription you could use one of your free support call to the Evil Empire or have all the TechNet subs expired now?

    Sorry was waffling. Try searching for that drive timeout problem on these Forums and then check and see if the same Registry Key is in Server 2012. If I have time tonight I will see if I can find the thread that Rems put a name to the setting and post the link back here.

    Found it. Have a read about 3 posts down. Autodisconnect
    Last edited by biggles77; 15th May 2014, 13:22.
    Joined: 23rd December 2003
    Departed: 23rd December 2015


    • #3
      Re: Mapped Drives show a red cross in Terminal Server 2012

      Did you ever find the cause\solution to this?

      I have an identical issue with a client and my google-fu is failing me.

      Thanks in advance.


      • #4
        Re: Mapped Drives show a red cross in Terminal Server 2012

        Have you tried adding redundancy to your DFS namespaces? If there are two locations that point to the data it may help
        A recent poll suggests that 6 out of 7 dwarfs are not happy


        • #5
          Re: Mapped Drives show a red cross in Terminal Server 2012

          The issue is caused by mapping to a DFS share, map directly to the server share and your problem is most likley to go away

          We had this exact issue, first user logs on ok, other users get red x, as soon as we found on the net it was related to mapping to the DFS share, we changed it to the direct share and it worked!


          • #6
            Re: Mapped Drives show a red cross in Terminal Server 2012

            Mapping direct to the share negates the whole purpose of DFS - a single namespace independent of servers etc.

            IMHO if things work OK and the problem is "merely" a visual cue (the red cross), just train the users a bit more and ignore it!
            Tom Jones
            MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
            PhD, MSc, FIAP, MIITT
            IT Trainer / Consultant
            Ossian Ltd

            ** Remember to give credit where credit is due and leave reputation points where appropriate **