Announcement

Collapse
No announcement yet.

Windows could not start the Cluster Service on Local computer.?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows could not start the Cluster Service on Local computer.?

    Dear Technet,

    Windows could not start the Cluster Service on Local computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code 2.


    My cluster suddenly went disappear. and tried to restart the cluster service. When trying to restart service this above mention error comes up.

    even i tried to remove the cluster through power-shell still couldn't happen because of cluster service not running.

    Help me please.. thank you.

    -

    Regards

    Shamil
    Attached Files

  • #2
    Re: Windows could not start the Cluster Service on Local computer.?

    More information please:
    Server OS
    Cluster configuration
    Where are shared volumes
    How is quorum checked
    What does the event log show
    What happened to make the cluster "suddenly disappear" (it doesn't do it by itself)

    Double post deleted
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: Windows could not start the Cluster Service on Local computer.?

      OS Windows server 2012,
      cluster configuration (With MD3200i as the Storage and Nodes as Dell R420 same spec.)
      Cluster storage drive as:
      Cluster volume dedicated drive 500GB
      Cluster volume dedicated drive 250GB
      Quorum drive 10GB

      None of the VM configured. before configuring cluster failed.

      Now once after boot up Both nodes getting hangs.

      After the cluster creation, i was busy with some other jobs. Yesterday only i noticed that cluster is missing from failover manager. When i am trying to connect to server (after browse from list of cluster) "Cluster <name> not found.

      Evenviewer:
      Failover cluster - Diagnostic
      [CS] Service CreateNodeThread Failed, ERROR_FILE_NOT_FOUND(2)' because of 'Open parameters key failed.'

      I am attaching eventviwer log also for ur reference.
      cluster-daig text i zipped because file size limitation.

      Regards and Thanks
      Shamil
      Attached Files
      Last edited by shamilsystems; 1st April 2014, 03:18. Reason: clarify more

      Comment


      • #4
        Re: Windows could not start the Cluster Service on Local computer.?

        May not be applicable but we have experienced a number of issues recently with WMI failing on one or two Hosts in the Cluster. As soon as that happens, you can't connect to the Cluster with the Failover Cluster Manager if opening a new session. As you don't appear to have that many Hosts, this may make your whole cluster fail. Fixing WMI resolved the issue on effected Hosts. The Cluster Manager expects to be able to access WMI on all Hosts within the Cluster to connect successfully.

        Article for reference: http://blogs.technet.com/b/supportin...2-cluster.aspx
        Last edited by Virtual; 1st April 2014, 10:57.

        Comment

        Working...
        X