Announcement

Collapse
No announcement yet.

RemoteApp publishing from 2012 to 7

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • RemoteApp publishing from 2012 to 7

    Hi

    I am trying to build a remoteapp role on my lab server 2012 , i have added the role and when i logon to https:/servername/rdweb everthing i can see the apps

    i have two questions regarding it

    1. when i try to enter one of the apps all the time a small screen comes and ask me to confirm (ports , printers .....) and then again ask me for user/password , how can i disable those screens ?

    2. when i try to add this server to my windows 7 remoteapp and desktop connection
    it fails since i dont have Certificate , how can i add cert to my server ?

    (we have local CA server)

    thanks

    TK

  • #2
    Re: RemoteApp publishing from 2012 to 7

    OK, I only have a 2008 R2 server with which to poke around, but hopefully the setup isn't radically different.

    1. Open the RemoteApp Manager. On my server, it comes up with an overview of all the different types of settings you can change, which is kind of ridiculous, since they all point to the same window, just a different tab. "RDP Settings" takes you to the right tab, "Common RDP Settings", where you can check/uncheck what gets passed thru to the individual sessions.

    2. You add certs using the Internet Information Services (IIS) Manager. Highlight the top of the tree in the left pane, which should be your servername. On my server, there are three sections: ASP.NET, IIS and Management. Under IIS, there is an applet for "Server Certificates", where you can create a self-signed cert. That should also be where you install the cert, but I didn't get that far.

    Comment


    • #3
      Re: RemoteApp publishing from 2012 to 7

      Hi

      thanks , as for the remoteapp setting i found it (on 2012 its different)
      but the cert issue i have created some selfsignd and added them

      but still from the client when i try to add the server i am getting this massege
      Attached Files

      Comment


      • #4
        Re: RemoteApp publishing from 2012 to 7

        Ah, that's because I neglected a step: distributing the cert to your users. Try this:

        http://www.maijen.nl/?p=163

        It's for a different service, but I don't imagine the steps are very different for RemoteApp

        Comment


        • #5
          Re: RemoteApp publishing from 2012 to 7

          Hi

          did it but still i am gettng the error

          i have attached it
          Attached Files

          Comment


          • #6
            Re: RemoteApp publishing from 2012 to 7

            If you have a CA then get it to issue you a cert for the RDWeb server. Make sure the common name matches the domain in the feed's URL.

            Don't mess around with self-signed certs. It's not worth it. If you don't have a local CA then pay the $100 bucks to get a 3rd party signed one. Makes life a whole lot easier and the cert pays for itself in time saved.
            Regards,
            Jeremy

            Network Consultant/Engineer
            Baltimore - Washington area and beyond
            www.gma-cpa.com

            Comment

            Working...
            X