Announcement

Collapse
No announcement yet.

New Users - Rights Problem(s)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • New Users - Rights Problem(s)

    Hi all,

    I have a pretty simple setup: File server with a folder called "UserData". Inside that is a folder for each user that upon logging in they should get as a "Z Drive".

    Ex:
    John Smith should have a Z drive connected to tob-file01\UserData\jsmith

    I have roughly 160 users in my AD 2012 environment and this works fine for them all.

    BUT! I just created two new users and they both have the same problem. BOTH of them, for a Z drive, seem to have the “UserData” root folder as opposed to their home folders in it. But weirder still is that, as you can see in the “New User” attachment, they don’t have ALL the user folders in UserData, only the 14 folders and 1 file you see there. And I can get into all of those folders and create a new file, so seemingly there is a rights problem (or more than one).

    Also, the "New User" attachment shows what happens when those users login to an XP machine. If I login either user to a Windows 7 PC, they get no Z drive mapped at all.

    HUH?!

    I'm really at a loss as to why this is happening, especially only for these two new users. Help?! Thanks!
    Attached Files

  • #2
    Re: New Users - Rights Problem(s)

    Can you run net use and post the output?

    Also, run
    Code:
    gpresult /h results.htm && ping localhost -n 1 & result.htm
    Look through the applied policy and see if there's any drive maps or scripts that map drives being applied.
    Regards,
    Jeremy

    Network Consultant/Engineer
    Baltimore - Washington area and beyond
    www.gma-cpa.com

    Comment


    • #3
      Re: New Users - Rights Problem(s)

      Run those from where, and logged in as who? From a client PC logged in as the user? From the FS as an admin? Something else?

      Comment


      • #4
        Re: New Users - Rights Problem(s)

        Run from the client as the user.
        Regards,
        Jeremy

        Network Consultant/Engineer
        Baltimore - Washington area and beyond
        www.gma-cpa.com

        Comment


        • #5
          Re: New Users - Rights Problem(s)

          See attached, sir. Thanks! This was from the XP client PC logged in as one of the users.
          Attached Files
          Last edited by WorldBuilder; 31st December 2013, 21:49.

          Comment


          • #6
            Re: New Users - Rights Problem(s)

            Sorry, didn't process the fact that this is an XP machine. So the gpresult command I gave you won't work.

            From the server, do you have the Group Policy Management console? If so, from there you can run the Resultant Set of Policy Wizard against the client computer.

            As for the net use command, something has mapped the Z: drive to the wrong location. So once you run the RSoP wizard we should be able to see if anything is pushing the wrong mapped drive.
            Regards,
            Jeremy

            Network Consultant/Engineer
            Baltimore - Washington area and beyond
            www.gma-cpa.com

            Comment


            • #7
              Re: New Users - Rights Problem(s)

              Here are the results from the Win7 PC. Slightly different, but expected based on the info from the OP.

              I also have the HTML file from running the GP wizard, but I can't attach it here...? I grabbed a screenshot of the only error in there, but that error makes sense because folder redirection shouldn't work.

              I'm not really sure what GP would have anything to do with anything here anyway, because the drive should be mapped not through GP, but as a profile path from AD.
              Attached Files

              Comment


              • #8
                Re: New Users - Rights Problem(s)

                Originally posted by WorldBuilder View Post
                Here are the results from the Win7 PC. Slightly different, but expected based on the info from the OP.

                I also have the HTML file from running the GP wizard, but I can't attach it here...? I grabbed a screenshot of the only error in there, but that error makes sense because folder redirection shouldn't work.

                I'm not really sure what GP would have anything to do with anything here anyway, because the drive should be mapped not through GP, but as a profile path from AD.
                The error is in the GPO.

                Folder Redirection did not work - Access denied.

                Does the user have the correct rights to create the relevant folder in the UserData folder?

                What happens if you try and create that folder then allow the user to connect?

                What happens if the user tries to create the folder in the UserData folder?

                Comment


                • #9
                  Re: New Users - Rights Problem(s)

                  This is interesting...

                  So I just looked at all the permissions.

                  Now, one thing I noticed was that on the SHARING tab, neither user was listed. They have Full Control in Security, but are not listed in the Share. I added them and... BAM! Works. But I must be missing something because I thought sharing was for when a folder was accessed locally as opposed to over the network...? So why would this not have worked until changing this? What have I got wrong?

                  ALSO! This is working on the XP client... I login either user and do get the correct folder mapping. But on Windows 7, even though I do now see the "Z Drive", if I try to go into it, I get the message attached.
                  Attached Files
                  Last edited by WorldBuilder; 1st January 2014, 15:05.

                  Comment


                  • #10
                    Re: New Users - Rights Problem(s)

                    Originally posted by WorldBuilder View Post
                    This is interesting...

                    So I just looked at all the permissions.

                    Now, one thing I noticed was that on the SHARING tab, neither user was listed. They have Full Control in Security, but are not listed in the Share. I added them and... BAM! Works. But I must be missing something because I thought sharing was for when a folder was accessed locally as opposed to over the network...? So why would this not have worked until changing this? What have I got wrong?

                    ALSO! This is working on the XP client... I login either user and do get the correct folder mapping. But on Windows 7, even though I do now see the "Z Drive", if I try to go into it, I get the message attached.
                    Sharing security is used when a folder is accessed from the network not locally.

                    Can you list the current permissions that you have set for the users home directory.

                    Comment


                    • #11
                      Re: New Users - Rights Problem(s)

                      Will do soon. I am thinking something is possibly wrong on a larger scale. Let me get into the office tomorrow (assuming I am not snowed in where I'm at) and I will post back here.

                      Thanks for all the help on this. Wanna make sure I get it right.

                      Comment

                      Working...
                      X