Announcement

Collapse
No announcement yet.

Windows server 2012 share permissions

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows server 2012 share permissions

    Hello Everyone,

    I've made a windows 2012 server to share files.
    It is located in domain A.
    Even tho I gave "everyone" and "guest" rights to certain folders, users outside domain A still have to enter their domain A credentials to access the shares.
    How do I make it that users outside (and inside) the domain aren't required to enter credentials when accessing a share?

  • #2
    Re: Windows server 2012 share permissions

    Have you checked the NTFS permissions too?
    (Share is only half the story)
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: Windows server 2012 share permissions

      Have you added the Anonymous security principal to the permissions? By default Everyone doesn't include anonymous users.

      http://technet.microsoft.com/en-us/l.../jj852264.aspx
      Regards,
      Jeremy

      Network Consultant/Engineer
      Baltimore - Washington area and beyond
      www.gma-cpa.com

      Comment


      • #4
        Re: Windows server 2012 share permissions

        Originally posted by Ossian View Post
        Have you checked the NTFS permissions too?
        (Share is only half the story)
        Yep, did that.

        Originally posted by JeremyW View Post
        Have you added the Anonymous security principal to the permissions? By default Everyone doesn't include anonymous users.

        <url>
        That I did not do. I'll try that out now.

        Comment


        • #5
          Re: Windows server 2012 share permissions

          Looked a bit further into it. Found this:
          Code:
          Change “Network access: Let Everyone permissions to apply to anonymous users” from Disabled to Enabled.
          Change “Network access: Restrict anonymous access to Named Pipes and Shares” from Enabled to Disabled.
          Enter in the share name for “Network access: Shares that can be accessed anonymously” - \\SERVERNAME\ShareName
          Tried it, but doesn't works.
          I'm out of ideas here

          Comment


          • #6
            Re: Windows server 2012 share permissions

            Is there a trust relationship between domains A and B?
            Tom Jones
            MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
            PhD, MSc, FIAP, MIITT
            IT Trainer / Consultant
            Ossian Ltd
            Scotland

            ** Remember to give credit where credit is due and leave reputation points where appropriate **

            Comment

            Working...
            X